Opened 6 years ago

Closed 6 years ago

#10492 closed Bug (invalid)

Javascript error: Unable to get property 'icons' of undefined or null reference - using unmodified samples directory

Reported by: cbashaw1 Owned by:
Priority: Normal Milestone:
Component: General Version: 4.1.1
Keywords: Cc:

Description

Hi,

Using CKEditor 4.1.1, only plugin added was StrInsert IE 10, Windows 7, Visual Studio 2012

After unzipped files, made no file changes of any kind: samples\index.html works fine using windows file explorer

Same unmodified samples directory when retrieved thru visual studio says "Unable to get property 'icons' of undefined or null reference" I have attached a screenshot.

To reproduce I added the unmodified CKEditor directory structure to my Visual Studio Project, set the samples\index.html as the 'startup page' and then clicked debug-go. Results in error shown in screenshot.

Ideas

Attachments (2)

Capture.png (107.1 KB) - added by cbashaw1 6 years ago.
screenshot of error message
Capture.2.png (79.9 KB) - added by cbashaw1 6 years ago.
screenshot of error after clicking view replace by code

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by cbashaw1

Attachment: Capture.png added

screenshot of error message

Changed 6 years ago by cbashaw1

Attachment: Capture.2.png added

screenshot of error after clicking view replace by code

comment:1 Changed 6 years ago by cbashaw1

I searched your issues database and I saw similar but not identical issues in previous releases having to do with browser compatibility mode but this didn't make any difference.

I also tried the same link http://localhost:60155/Content/CKEditor/samples/replacebycode.html in Google Chrome version 27.01453.94, and though it didn't give me any error messages it also just didn't display the textarea, just a blank area where it should be with a submit button beneath.

comment:2 Changed 6 years ago by cbashaw1

Found the solution for me.

I used Visual Studio to debug the javascript and saw that the exception occurs while running thru the list of plugins where as it turns out the 'panel' plugin had a null value and so panel.icons throws this exception.

To fix; I redownloaded the install set of "CKEditor 4.1.1 with plugin StrInsert like before - but this time I also included the plugin for 'panel'; installed and retested and all worked correctly for me. Must be 'panel' plugin was required but install didn't auto include it.

Thanx, chris

comment:3 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

First of all thank you for the feedback.

I have tried using builder http://ckeditor.com/builder and it has worked correctly i.e. when StrInsert plugin was selected Panel, Rich Combo, floating Panel and List Block all were included in the build.

My guess is that you have downloaded Basic editor which doesn't include Dropdowns. Next you have downloaded strInsert separately. Next you have included plugin into editor manually.

If that was the case then this this ticket isn't valid and you already know that StrInsert requires Rich Combo which requires few plugins. If you have got this error using builder, please describe exact steps to reproduce this as this may be a bug.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy