Opened 6 years ago

Closed 6 years ago

#10498 closed Bug (invalid)

Pasting from Outlook causes infinite loop

Reported by: Piotrek Koszuliński Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

Follow-up of #10285 (http://dev.ckeditor.com/ticket/10285#comment:12)

I would like to mention that this still occurs. We noticed then when we tried to paste from Outlook to CKEditor.

To reproduce:

  1. open any html email in Outlook ( I used 2013 )
  2. copy html content, ctrl-a / ctrl-c
  3. past content into ckeditor ctrl-v, or click the paste button

The entire browser becomes unresponsive, and has to be killed.

config.fullPage         = true                        # Allow full page HTML
config.uiColor          = '#f5f5f5'                   # Match the main site background
config.skin             = 'moonocolor'                # Skins are kept in app/assets/javascripts/ckeditor/skins
config.toolbar          = ts_inline_toolbar           # Base toolbar used on all editors
config.enterMode        = CKEDITOR.ENTER_BR           # Disable wrapping content in <p> elements (needed for inline editing)
config.pasteFromWordRemoveFontStyles = false
config.autoParagraph = false

Attachments (1)

config.js (1.7 KB) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Description: modified (diff)

comment:2 Changed 6 years ago by Piotrek Koszuliński

Status: newpending
  • Which CKEditor version do you use?
  • If >4.1 - what's your toolbar configuration?
  • On which browser(s) does this happen?

comment:3 Changed 6 years ago by Piotrek Koszuliński

Description: modified (diff)

comment:4 Changed 6 years ago by Mike Kelley

Which CKEditor version do you use? - 4.1.1

If >4.1 - what's your toolbar configuration?

var ts_base_toolbar = [
  {
    name: 'document',
    items: ['Source']
  }, {
    name: 'tools',
    items: ['Maximize']
  }, {
    name: 'clipboard',
    items: ['Cut', 'Copy', 'Paste', 'PasteText', 'PasteFromWord', '-', 'Undo', 'Redo']
  }, {
    name: 'editing',
    items: ['Find', 'Replace', 'SelectAll']
  }, {
    name: 'forms',
    items: ['Form', 'Checkbox', 'Radio', 'TextField', 'TextArea', 'Select', 'Button', 'ImageButton', 'HiddenField']
  }, '/', {
    name: 'basicstyles',
    items: ['Bold', 'Italic', 'Strike', '-', 'RemoveFormat']
  }, {
    name: 'paragraph',
    items: ['NumberedList', 'BulletedList', '-', 'Outdent', 'Indent', '-', 'Blockquote', 'JustifyLeft', 'JustifyCenter', 'JustifyRight', 'JustifyBlock']
  }, {
    name: 'links',
    items: ['Link', 'Unlink', 'Anchor']
  }, {
    name: 'insert',
    items: ['Image', 'Table', 'HorizontalRule', 'SpecialChar', 'PageBreak', 'Iframe']
  }, '/', {
    name: 'styles',
    items: ['Styles', 'Format', 'Font', 'FontSize', 'TextColor', 'BGColor']
  }
];

On which browser(s) does this happen? - IE 8 and 9, Chrome (windows), Firefox (windows)

Full config here: https://gist.github.com/gitt/aa2b28ea5de76d1dbc5e

Changed 6 years ago by Jakub Ś

Attachment: config.js added

comment:5 Changed 6 years ago by Jakub Ś

I have tried your settings (all except moonocolor) but I wasn't able to reproduce this problem.

  1. Perhaps this has something to do with what you have in your email. Could you create sample email that causes problems for you and send it to us? Screenshot of your email is also welcome.
  2. Have you made any changes to editor core code? Does it happen in default editor with only your config.js changed?
  3. One more thing - does it happen with every email or perhaps one specific?
Last edited 6 years ago by Jakub Ś (previous) (diff)

comment:6 Changed 6 years ago by Mike Kelley

This ended up being caused by the ckeditor files being stored on s3. The part I don't understand is why that would cause it, and only in windows.

comment:7 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

The only thing that comes to my mind is that on S3 paste from Word's filter couldn't be loaded for some reason. It is loaded on demand on first paste from Word-like document. We'd be grateful if you could try to simplify that issue or let us check real example.

I'm closing this issue. We can open new one for that specific case.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy