Opened 6 years ago

Closed 6 years ago

#10508 closed Bug (fixed)

Incorrect behavior when undo/redo clicked in IE

Reported by: Irina Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.2
Keywords: IBM IE Cc: Teresa Monahan, Satya Minnekanti

Description

Browser: IE8/9

Steps to reproduce:

  1. Type in at least 10 lines of random words (as this issue is not reproducible with a short list of words)
  2. Click undo few times.

Actual Result:

The 1st time Undo pressed: the cursor moves to the previous line as expected.

The 2nd time Undo pressed: the cursor jumps back to the next empty line instead of moving to the previous line.

Also, if editor will be configured to use the ENTER_DIV mode, then, occasionally, the last letter in the previous line will disappear and then appear again if keep pressing the undo button.

Change History (7)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: IE added
Status: newconfirmed
Version: 3.6.6 (SVN - trunk)3.6.2

Problem can be reproduced in all versions of IE from CKEditor 3.6.2 rev. [7255] till 3.6.6

It works fine in CKE 4.x. I'm confirming this ticket but is there possibility that you can switch to CKE 4.x and this ticket could be closed?

comment:2 Changed 6 years ago by Steve Rutland

This problem exhibits in CKE 4.2 as well. Just checked and reproduced it several times. Using IE9 (Win7) in a Drupal 7 environment. To reproduce, type about 10 words, then copy these 10 words and paste them a couple of times after the typed words. Then try using undo.

It might be an intermittent problem.

comment:3 Changed 6 years ago by Jakub Ś

It might be an intermittent problem.

What do you mean by that? Could you provide detailed step by step scenario to reproduce?

I have tried above steps and your steps in CKEditor 4.2 and no problem occurred. The only thing that might be considered a problem is that Undo has limited number of steps but this can be configured - http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-undoStackSize.

@srutland if you think otherwise please provide step by steps scenario to reproduce with description what is happening as "there might be problem" is just too little information.

comment:4 Changed 6 years ago by Steve Rutland

My apologies for an incomplete test description. Repeat the following test several times and the error will most likely appear:

To reproduce Use IE9 Win7

  • 1) Create new Page (we're using Drupal 7)
  • 2) Save then Edit
  • 3) Type about 10 words (I type "one two three four five six seven eight nine ten")
  • 4) Select and copy the ten words you just typed
  • 5) Paste the string at the end of the typed line several times (paste it 3 or 4 times)
  • 6) Then try using the undo button.
    • the first undo removes the last paste (and the cursor may jump and display at the far right of the editor window nowhere near the text)
    • the second undo puts the text back in
    • the third undo may do nothing or (intermittently garble the text)

I don't believe it's a history problem because undo works fine in Chrome, FF23, and Safari allowing multiple undos. Only IE9 is exhibiting the described behavior

*Please try this procedure several times as the error tends to vary with iteration*

Thanks!

comment:5 Changed 6 years ago by Jakub Ś

@srutland I haven't been able to reproduce this problem in CKE 4.x. Could you perhaps provide a screen cast for this issue?

comment:6 in reply to:  5 Changed 6 years ago by Steve Rutland

Replying to j.swiderski:

@srutland I haven't been able to reproduce this problem in CKE 4.x. Could you perhaps provide a screen cast for this issue?

This problem has been fixed in v4.2.1 via http://dev.ckeditor.com/ticket/10301.

comment:7 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

Thank you for the comment.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy