Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#1051 closed Bug (wontfix)

The Fckeditor paste command is not executed on using Command +V on Mac firefox

Reported by: Kapil Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6
Component: General Version: FCKeditor 2.4.3
Keywords: Confirmed Firefox Mac CantFix Cc: kagupta@…

Description

The fckeditor's named command 'paste' is not executed on pressing command+V in Mac firefox. So it is not possible to intercept the paste command on Mac firefox. This works fine on Windows using Ctrl+V but similar behaviour is not shown with command+V on mac.

Change History (6)

comment:1 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Milestone: FCKeditor 2.6
Priority: HighNormal

This looks like a bug in Firefox. Setting target to 2.6 so it's reported in bmo

comment:2 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed Firefox added

comment:3 Changed 11 years ago by Wojciech Olchawa

Keywords: Mac added

comment:4 Changed 11 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:5 Changed 11 years ago by Martin Kou

Keywords: CantFix added
Resolution: wontfix
Status: assignedclosed

I did some tests and found that all Meta key combos cannot be intercepted by JavaScript in Firefox for Mac (although the meta key itself can sometimes be intercepted). So this is definitely a Gecko bug.

I've filed a bug report to the Mozilla devs at: https://bugzilla.mozilla.org/show_bug.cgi?id=418334

Other than reporting the bug, I don't think there's anything we can do to fix this issue in JavaScript.

comment:6 Changed 11 years ago by Martin Kou

#2144 is marked as a dup of this bug.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy