Opened 7 years ago

Closed 7 years ago

#10510 closed Bug (fixed)

Editor should have unique label

Reported by: Teresa Monahan Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.1.2
Component: Accessibility Version: 3.0
Keywords: IBM Cc: Satya Minnekanti, Irina

Description

At present the aria-labelledby element of the editor contains the value "Rich Text Editor". This means that if 2 editors are on the same page, there is no way for JAWS users to differentiate between the application landmarks for the editors. The aria-labelledby element should instead contain a unique value for each editor.

One simple way to address this is to include the editor name in the value e.g. "Rich Text Editor, editor1", "Rich Text Editor, editor2" etc. This can be achieved by replacing:

voiceLabel: editor.lang.editor,

with:

voiceLabel: [ editor.lang.editor, editor.name ].join( ',' ),

on line 327 of core/creators/themedui/js.

This is an accessibility requirement for us so is a high priority. Can this please be included in the upcoming 4.1.2 release?

Change History (8)

comment:1 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

I believe this is a duplicate of #10042.

AFAIK JAWS reads something like Rich Text Editor, editor one.

@tmonahan I'm closing this as duplicate. If you think otherwise please leave a comment.

comment:2 in reply to:  1 Changed 7 years ago by Teresa Monahan

Replying to j.swiderski:

I believe this is a duplicate of #10042.

AFAIK JAWS reads something like Rich Text Editor, editor one.

@tmonahan I'm closing this as duplicate. If you think otherwise please leave a comment.

Hi, thanks for the link to ticket #10042 - that is interesting and will definitely be useful for us. Unfortunately this ticket requires a little more. The issue described here does not relate to what JAWS reads out when users tab to the editor. Instead it is about how users can identify landmarks on a page. There is a shortcut in JAWS which lists all available landmarks - Ctrl + Insert + ;

Currently all editors on the page are listed as "Rich Text Editor Application" because the element with role=application has "Rich Text Editor" as its associated label. We need editors to be distinguishable on this list. Changing the voiceLabel in themedui.js to use the new editor.title value should be enough to achieve this:

voiceLabel: editor.title,

comment:3 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: closedreopened

Thanks for clarification. I will forward this ticket.

comment:4 Changed 7 years ago by Jakub Ś

Status: reopenedconfirmed
Version: 4.1.2 (GitHub - master)3.0

comment:5 Changed 7 years ago by Olek Nowodziński

Milestone: CKEditor 4.1.2

Since the problem only refers to a11y and the solution seems non-intrusive, it's possible to have it in 4.1.2.

comment:6 in reply to:  5 Changed 7 years ago by Teresa Monahan

Replying to a.nowodzinski:

Since the problem only refers to a11y and the solution seems non-intrusive, it's possible to have it in 4.1.2.

Great, thanks!

comment:7 Changed 7 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedreview

Pushed the fix to t/10510 branch.

comment:8 Changed 7 years ago by Olek Nowodziński

Resolution: fixed
Status: reviewclosed

Merged fix into master, dev (​git:a9dc6c374653eb).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy