Opened 6 years ago

Closed 6 years ago

#10587 closed Bug (wontfix)

CKEDITOR DISALLOWS DRAG&DROP PAST DISPLAY AREA

Reported by: Zoltan Koszegi Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: oracle Cc: tracy.nakanishi@…

Description

Tested with IE8 & IE10.
Steps To Recreate:
1) Create a page with 2x more text than fits in your window display. (Vertical scroll bar appears.)
2) Click somewhere in middle of the page then click 'Insert Table'.
3) Make a table of any size and accept.
4) Click the upper-left corner to drag the table to the bottom.

RESULT You can not scroll during drag in a way that allows you to reach the bottom of the page. You also can not mouse-wheel to move the display while you have the selection.

This also happens with anything else you try to drag and drop (text selections, images and so on). That is: You can drag to create a selection and the editor will scroll, but if you already have a selection you are trying to drag&drop, you cannot scroll past the display.

Compare to, say, MS Word where it auto-scrolls when you get near the top or bottom of the display area, or to MS Paint where you can select past what you can see /and/ can wheel to change your view.

Attachments (1)

_template_html5.html (31.5 KB) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (2)

comment:1 Changed 6 years ago by Jakub Ś

Resolution: wontfix
Status: newclosed
Version: 4.1.1

Please check attached file - it has body with contenteditable attribute (no editor).

You can grab table but won't be able to scroll browser so this issue is caused by browser itself and is a won't fix issue.

Good news is that if you move table to the bottom of viewport or editor editing area it is possible to move down to the bottom of page.

Changed 6 years ago by Jakub Ś

Attachment: _template_html5.html added
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy