Opened 6 years ago

Closed 5 years ago

#10622 closed Bug (expired)

Under specific scenario, "Enter" inserts new line but resets cursor to beginning of line 1

Reported by: Ben Fariello Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce -

1) Shift+Enter" to start a new line without the normal space between paragraphs 2) "Backspace" to return to the previous line 3) "Enter" to begin a new line with the space between paragraphs 4) The cursor has jumped to the beginning of line 1, and if you type now it appears at the beginning of the text field.

Browser and OS - OSX (10.7.5) using Google Chrome (Version 27.0.1453.116)

  • I was told that this does not occur in Windows 7, Chrome v27

Screenshot - N/A

Sample data - N/A

Test case file - N/A

Build configuration - N/A

Change History (5)

comment:1 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: newclosed

I wasn't able to reproduce this problem. I have tried latest editor 4.2, empty and with content but cursor didn't jump.

The latest Chrome version is 29 at the time of writing. Perhaps this issue has been fixed in latest Chrome version.

@bdfariello I'm closing this as fixed but please feel free to leave a comment if you are still able to reproduce it.

comment:2 Changed 6 years ago by Ben Fariello

I reproduced this again today on the same Demo page using those same three steps. As I mentioned in the original ticket, this was not reproducible with Chrome on Windows. It seems OS-dependent.

Current Browser and OS: OSX 10.9.1 (I have since upgraded to Mavericks), Chrome 32.0.1700.107.

---

As a side-note, it seems strange that this ticketing system doesn't have the ability to close something as "Works For Me" or "Could Not Reproduce". Closing this as "Fixed" when no changes were made is an odd way for this ticketing system to function.

comment:3 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: closedreopened

comment:4 Changed 6 years ago by Jakub Ś

Status: reopenedpending

As a side-note, it seems strange that this ticketing system doesn't have the ability to close something as "Works For Me"

That was by mistake. We have Fixed and "Works for me" in one dropdown so I have probably missed it and hit the wrong option.


I have just tried Mavericks and Chrome 32 and didn't get this issue. Perhaps you have missed something in your description. Please tell me:

  • Which editor you use in our demo?
  • What do you do with initial data? Do you remove it or test inside it?
  • Could you provide screen-cast of this problem?

comment:5 Changed 5 years ago by Piotrek Koszuliński

Resolution: expired
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy