Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10661 closed Bug (invalid)

Shared space plugin strips classes when "top" toolbar is enabled

Reported by: Kevin Kamel Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hi,

This seemingly is an ACF problem within the shared space plugin. To see the issue simply replace the sharedspace.html sample file with the one attached to the ticket. You will see that the "class" and "id" fields from the source are stripped in the ckeditor rendering.

This file is *barely* modified, all I did was add classes/ids to 2 elements within the editable areas. All end up being stripped.

Note that the elements are stripped both from the inline as well as the standard editor views.

If I disable ACF, the classes remain - but obviously that's a poor fix. I prefer to keep ACF in place.

Suggestions on handling this in production are appreciated.

appears that I cannot add attachments, going to attempt to add it after filing.

Attachments (1)

sharedspace.html (4.0 KB) - added by Kevin Kamel 6 years ago.
replacement sample for sharedspace path showing how class and id are stripped

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Kevin Kamel

Attachment: sharedspace.html added

replacement sample for sharedspace path showing how class and id are stripped

comment:1 Changed 6 years ago by Kevin Kamel

Additional note - if I do not use shared space, but instead let it use separate toolbars, this issue completely goes away.

comment:2 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed

This is exactly how ACF works. Those class and id are not allowed by default set of rules, so they are stripped. To allow them just add:

extraAllowedContent: '*[id](wtf)'

Also, I removed sharedspace plugin from that sample and those class&id were still stripped out. Sharedspace has nothing to do with ACF.

comment:3 in reply to:  2 Changed 6 years ago by Kevin Kamel

You should ask for more information in such cases. I specifically talk about how I am familiar with ACF. Your reply does not indicate that the issue is invalid, it indicates that you didn't understand my ticket and need more information.

I will refile this one since there is no way for me to reopen or to have a dialog with you. I will attach a more obvious example since you apparently could not see it, despite it being obvious.

As noted before, If you use shared space (or floating) all class and id are stripped. If you use a standard toolbar, everything works. My example will show all 3 cases for you.

In several places in CKEditor you say "see the example in Sample Space". That example is broken. If you go there and attempt to "highlight" content, it will not work. Why? Because there is a bug preventing it from working. This bug is not present when you do not use the inline editor - it only is present when you do.

comment:4 Changed 6 years ago by Kevin Kamel

New ticket created with additional information, it's here:

https://dev.ckeditor.com/ticket/10662

comment:5 Changed 6 years ago by Piotrek Koszuliński

You should ask for more information in such cases. I specifically talk about how I am familiar with ACF. Your reply does not indicate that the issue is invalid, it indicates that you didn't understand my ticket and need more information.

You're just rude now. Your ticket was invalid. I couldn't know that you have forgotten to give some critically important information, that's why I closed it. But this doesn't mean I'm right and that this is EOT - we're always opened for a discussion. It sometimes happens that ticket is reopened after we're given more details.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy