Opened 6 years ago

Closed 6 years ago

#10721 closed Bug (duplicate)

Cannot remove a style that is copied from another inline ckeditor

Reported by: Mandeep Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I have multiple inline ckeditors. I have css style for the p tag inside the inline ckeditor div. That style contains a line-height attribute. What happens is that if I try to copy some styled elements from one editor to another, I am not able to undo those styles.

Steps to reproduce:

  1. Have minimum two inline ckeditors
  2. Write some text in one ckeditor
  3. Make that text bold
  4. Copy that text into another ckeditor
  5. select that text and try to unbold it.
  6. It doesnt work

I was able to reproduce it for bold,italic,underline and strike formatting options.

It worked fine with text-color, background-color and paragraph format. You can test for the rest if you feel like.

Here is the jsfiddle demonstrating the issue. http://jsfiddle.net/FLZhn/8/

I was able to reproduce it in 4.0.1 and 4.0.2 I am using google chrome 28. Didnt test in ff and ie.

Let me know if you need any more info.

Change History (1)

comment:1 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
  1. Webkit copies styles like that.
  2. Your issue is a duplicate of #8369
  3. You could workaround it a little bit with http://dev.ckeditor.com/ticket/8686#comment:8.

    If you set editor to use span as bold it will unbold e.g. <span style="font-family:Batang; font-weight:bold">Bold</span> and leave other styles untouched.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy