Opened 6 years ago

Closed 4 years ago

#10724 closed Bug (fixed)

SCAYT conflicts with FF text highlighting via the keyboard on misspelled words

Reported by: cjarczew Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 3.5.1
Keywords: Firefox IE10 Cc: WebSpellChecker.net

Description

SCAYT causes partial lines to be highlighted in FF not allowing the user to easily cut/copy the content they want when using the keyboard to highlight text(Shift + End, Shift + CTRL + Right Arrow)

Browser: FF 22.0

OS: Win 7

Reproducible location: Demo site and nightly build

I tested with IE9.0.8112.16421 and Chrome 28.0.1500.95 m as well and both seemed to work just fine.

Steps to reproduce:

  1. Go to the demo site
  2. Delete all sample content from the editor
  3. Enable SCAYT
  4. Type in a line with correct and incorrect words such as: "Hi there, how arre you?
  5. Place the cursor at the start of the line and then hold Shift and press End.

Once you release the keys you will notice SOMETIMES the text will first highlight the whole line as expected and then within a second will highlight just the text up to the first spelling mistake which in this case is 'arre'.

If you look at the HTML generated you will see this for the above:

<p>Hi there, how <span data-scaytid="1" data-scayt_word="arre">arre</span> you?<br></p>

The text will highlight up to the beginning of the span tag caused by SCAYT.

NOTE: Seems to only fail going left to right on a line, if I go right to left it highlights fine.

Attachments (2)

FF.png (3.9 KB) - added by Jakub Ś 6 years ago.
IE.png (10.6 KB) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: Firefox IE10 added
Status: newconfirmed
Version: 4.3 (GitHub - major)3.5.1

I was able to reproduce this in Firefox 23 from CKEditor 3.5.1 and IE10 from CKEditor 3.6.6 (when IE10 has started being supported). My test results were a little different (please see screen shots) but selection is gone partialy.

Changed 6 years ago by Jakub Ś

Attachment: FF.png added

Changed 6 years ago by Jakub Ś

Attachment: IE.png added

comment:2 Changed 6 years ago by Jakub Ś

Cc: WebSpellChecker.net added

comment:3 Changed 5 years ago by Wiktor Walc

Component: GeneralUI : Spell Checker

comment:4 Changed 4 years ago by Wiktor Walc

Status: confirmedpending

Unable to reproduce it, can you confirm that the issue is gone?

comment:5 Changed 4 years ago by Jakub Ś

Resolution: fixed
Status: pendingclosed

I confirm issue is now gone.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy