Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10732 closed New Feature (invalid)

Add <dl> <dt> <dd> support

Reported by: Eric GELOEN Owned by:
Priority: Normal Milestone:
Component: General Version: 4.2.1
Keywords: Cc:

Description

Hey!

I'm currently trying to insert <dt>, <dl> or <dd> html tag directly in the source view. When I go back to the preview view then my tags are replaced by simple <p> tags.

IMO, CKEditor should support these tags in his parser.

To reproduce, simply add these code:

<dl>

<dt>This is the test</dt> <dd>And it refuses to work</dd>

</dl>

Regards

Change History (3)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed

Read about Advanced Content Filter. There's no support in CKEditor itself for definition lists (there's a ticket already for this), so those elements are stripped. However, ACF can be configured to not do this.

comment:2 Changed 6 years ago by sirtet

Type: BugNew Feature

the configuration in question is

CKEDITOR.config.allowedContent = true

this will prevent the tags from being converted, but there's no editing-support in WYSIWYG mode like adding a DT after entering a DD.

comment:3 Changed 6 years ago by sirtet

This is a Duplicate of ticket #1333 (it's the one Reinmar mentioned in comment:1)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy