Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10754 closed Bug (duplicate)

[Full page editing] Lost nodetype when deleting line

Reported by: leliahel Owned by:
Priority: Normal Milestone:
Component: Core : Editable Version:
Keywords: Cc:

Description

Steps to reproduce

Go to http://ckeditor.com/demo#full-page
Insert new title, say h1.
Newline, another title, say h2.

You should have the following:

First line

Second line

Now delete the first line and delete the line break.

You should now have:

Second line

But instead we got:

Second line

Which is not the expected behavior.

Change History (3)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Keywords: full page edit delete line removed
Resolution: duplicate
Status: newclosed
Version: 4.2.1 (GitHub - master)

Am I right that this is a duplicate of #9998? It happens only on Webkit/Blink based browsers and the inline span with dozen of styles is created. We reported a set of related issues on Webkit/Blink dev sites, but no one responded for few months.

comment:2 Changed 6 years ago by leliahel

Well it does look like #9998 but mine only occur when CKEDITOR is configured for full page edit so... We might want to add an explanation for this bug to the previous one.

And yeah I checked and it's only chrome.

Sorry for the duplicate, I was unable to find the previous one since I didn't know what to look for.

Hope this gonna be fix soon or one day...

Thanks for the reply !

comment:3 Changed 6 years ago by Piotrek Koszuliński

The thing that makes a difference is styling. Engines differently handle backspaces/enter/delete depending on which styles are applied to which elements. So perhaps when you're testing the full page you may be testing a little bit different case than happens in normal editor, but the source of problem is the same.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy