Opened 6 years ago

Closed 5 years ago

#10762 closed Bug (fixed)

IE - preview displays JS code in URL bar

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone: CKEditor 4.3.2
Component: General Version: 4.1.2
Keywords: IE Cc:

Description (last modified by Jakub Ś)

I was able to reproduce this on IE8-10.

Problem has started occurring in version 4.1.2. When you press preview button (use replacebycode.html) you get instead of about:blank in URL bar, something like below:

javascript:void( (function(){document.open();(function(){for(var a;;)try{a=window.window.opener.document.domain;break}catch(b){a=a?a.replace(/.+?(?:\.|$)/,""):document.domain;if(!a)break;document.domain=a}return!!a})();document.write( window.opener._cke_htmlToLoad );document.close();window.opener._cke_htmlToLoad = null;})() )

Page is still displayed but this URL looks ugly. Additionally this causes preview plugin not working in git version because besides code there are also comments which seem to break URL - Ie can't read it and page isn't displayed.

Change History (6)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 6 years ago by Jakub Ś

Only IE11 seems to work fine here. It displays URL like http://localhost:9999/ckeditor-git/plugins/preview/preview.html

Last edited 6 years ago by Jakub Ś (previous) (diff)

comment:3 Changed 6 years ago by Jakub Ś

Description: modified (diff)
Summary: IE - preview is not working.IE - preview displays JS code in URL bar

comment:4 Changed 5 years ago by Marek Lewandowski

comment:5 Changed 5 years ago by Olek Nowodziński

Milestone: CKEditor 4.3.2

Solved in #11146.

comment:6 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Fixed by #11146.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy