Opened 6 years ago

Closed 6 years ago

#10797 closed Bug (invalid)

IE10 update from version 10.0.7 to 10.0.8 (KB2862772) makes CKEditor unfocusable

Reported by: Lefebvre Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

As suggested in http://ckeditor.com/forums/Support/IE10-update-from-version-10.0.7-to-10.0.8-KB2862772-makes-CKEditor-readonly-mode, I'm opening a new ticket here.

this is a copy of post:

Hi,

Our team and customers recently get a weird behavior on IE10, when ckeditor is reloaded, all controls of page cannot have focus anymore, even ckeditor is unfocusable, we encounter this problem only with IE10 v10.0.8 and not with IE10 v10.0.7 (last kb patch was 2862772 for IE). Did somebody encountered the same problem ?

Used version of CKEditor: 4.0.3

Update: our servers with IE9 have been updated with this patch, same problem.

Update: Test case http://jsfiddle.net/Xf3n2/1/ , must be used with IE10 up to date (About -> Update Versions: 10.0.8 (KB2862772)) Step1: click on reload, type something in ckeditor Step2: click on reload, focus is lost from ckeditor (it's normal) Step3: CKEditor and textbox above cannot gain focus again Here is a video (swf format) for people who don't have IE10 and want to see what the problem is: https://docs.google.com/file/d/0B3Q1AOjSDtMIb2hhWFJ5OVZRSGs/edit?usp=sharing

Lefebvre Xavier

Change History (2)

comment:1 Changed 6 years ago by Lefebvre

Version: 4.0.34.2

Used version of ckeditor for our solution is 4.0.3 as written in ticked. But this jsFiddle test with last version of ckeditor (4.2) has the bug too: http://jsfiddle.net/Xf3n2/2/

comment:2 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.2

I don't want to sound rude but I don't care if it had worked before because what you do here is very wrong.

You reload is in fact assigning new textarea to container div. You don't bother to destroy old instance of editor with its DOKM and event handlers and you simply replace whole with new textarea. This isn't how you do it.

  1. Please check AJAX sample in ckeditor samples folder to get better view ho it can be done.
  2. I'm not sure why you insert textarea if you can have it in that div. Your code should rather look like this (if you don't want to use what is in ajax.html sample):
    $(window).load(function(){
    var editor; 
    $('#reloadCKeditor').click(function(){    
    	if(editor){
    		editor.destroy();
    		editor = null;
    	}		
    	document.getElementById('myCkeditor').innerHTML='';	
        editor = CKEDITOR.replace( 'myCkeditor' )}
    });
    });
    
  3. If you need to create textarea on the fly you should rather use:
    $(window).load(function(){
    var editor; 
    $('#reloadCKeditor').click(function(){    
    	if(editor){
    		editor.destroy();
    		editor = null;
    	}			
    	$('#myCkeditor').empty();
    	$('#ckeditors_container').html(' <textarea ID="myCkeditor" cols="80" rows="10"></textarea> ');
        editor = CKEDITOR.replace( 'myCkeditor' )}
    });
    });
    

The above code works - it still needs about 1 sec to load full features of editor but content area is responsive.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy