Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10800 closed Bug (duplicate)

CKEditor doesn't apply inline styles to links

Reported by: Bhadresh Shiroya1 Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version:
Keywords: Cc:

Description

CKEDITOR.addStylesSet( 'my_styles', [

{ name : 'Red',type: CKEDITOR.STYLE_INLINE, element : 'a', attributes : { 'style' : 'color:#f00;text-decoration:none;' } }

]);

CKEDITOR.config.stylesCombo_stylesSet = 'my_styles';


1) Anchor is not getting displayed.

2) When you have a text which is styled with Emphasis and Marker Green, it does not allow you to move to the next line(pressing enter key results into nothing)

3) The Style, Format and Font Dropdowns are transparent and hence you can see the content of the textbox in the background. I am not sure if this is done deliberately but it doesn’t look good.

4) If you right click on the editor and traverse upto the submenu and make a selection(e.g. Insert row below) then after selection the submenu still shows.

Attachments (1)

cki.jpg (33.7 KB) - added by Bhadresh Shiroya1 6 years ago.

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by Bhadresh Shiroya1

Attachment: cki.jpg added

comment:1 Changed 6 years ago by Piotrek Koszuliński

Component: Server : JavaCore : Styles
Keywords: dropdown style move the link upwords removed
Resolution: duplicate
Status: newclosed
Version: FCKeditor.Java 2.6

Duplicates #9349.

comment:2 Changed 6 years ago by Bhadresh Shiroya1

same error ,

Last edited 6 years ago by Bhadresh Shiroya1 (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy