Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10826 closed Bug (worksforme)

Menubutton focus does not go back to editor after picking an option

Reported by: Marek Lewandowski Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Issue is reproducable with Chrome/31.0.1627.0

You can test issue using languages plugin.

  1. Open any sample with CKEditor languages plugin enabled (i.e. samples/replacebyclass.html).
  2. Select any text.
  3. Navigate using keyboard to language plugin button (the chinese character button).
  4. Unfold button using i.e. space key, then using keyboard pick any option from available languages (i.e. with space key).

Expected result:
Focus should return to the editor content.

Current result:
Focus is not set to editor.

additional info:

  1. My assumption are that focus stays still within dropbox on <a /> element for selected language, because we can see javascript:void('French') in browser status bar, and hitting (shift+) tab key will change it to any other language. Also it can be checked by activeElement, checking document.getElementById('cke_105_frame').contentDocument.activeElement (assuming that cke_105_frame is id of iframe created by CKEditor).

Change History (2)

comment:1 Changed 6 years ago by Jakub Ś

Status: newpending

@m.lewandowski could you recheck it? I have tried in latest stable Chrome 29 and problem doesn't occur there. Btw. latest beta is 30 not 31. I have also checked beta and there is no problem there as well.

Last edited 6 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 6 years ago by Marek Lewandowski

Resolution: worksforme
Status: pendingclosed

@j.swiderski - version 31 is currently available as nigthly build. I've checked major, and issue does not occur anymore :) I recall that language menubutton usage was changed a little while ago, so maybe that fixed the issue. Anyway: closed

Last edited 6 years ago by Marek Lewandowski (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy