Opened 6 years ago

Closed 6 years ago

#10850 closed Bug (fixed)

[Firefox] Undoing bold on entire table restores only a part of the selection

Reported by: Olek Nowodziński Owned by:
Priority: Normal Milestone: CKEditor 4.2.2
Component: Core : Selection Version: 4.2.1
Keywords: Cc:

Description

  1. Use the following HTML in replacebycode:
    <table border="1" cellpadding="1" cellspacing="1" style="width:500px">
    	<tbody>
    		<tr>
    			<td>a</td>
    			<td>b</td>
    		</tr>
    		<tr>
    			<td>c</td>
    			<td>d</td>
    		</tr>
    	</tbody>
    </table>
    
  2. Select all table cells with mouse.
  3. CTRL+B.
  4. CTRL+Z.
  5. Note that only the first column remains selected. Expected: The entire table is selected.

I'm unable to reproduce it in different browser. I guess this is mostly because of the fancy way Firefox selects table cells with mouse.

First bad commit: git:7f7a7aaa2135

This issue is correlated with #10812.

Change History (1)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: newclosed

Fixed by #10812.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy