Opened 5 years ago

Closed 5 years ago

#10877 closed Bug (fixed)

[Blink/Webkit] WSC fails to apply changes if nested editable was focused

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.3
Component: General Version: 4.3 Beta
Keywords: Cc:

Description

  1. Open image2 sample.
  2. Place caret in nested editable.
  3. Open WSC.
  4. Click "change to" at least once.
  5. Click "finish checking". Error is thrown.

Change History (8)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:2 Changed 5 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:3 Changed 5 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed t/10877 on dev and tests.

I'm not 100% sure if this is the best solution, because it may mute other bugs which will cause calling the updateCommandsContext in inappropriate moments.

It'd be cool if we could assure that selection always exist, but this is A LOT MORE complicated. So I'm proposing this simple check.

comment:4 Changed 5 years ago by Piotrek Koszuliński

BTW. The stack trace of the error mentioned in the description:

  1. contentDomUnload (WSC dialog calls setData when it is closed)
  2. editor.widgets.destroyAll
  3. editor.setActiveFilter( null ) (because nested editable is blurred)
  4. updateCommandsContext

comment:5 Changed 5 years ago by Piotrek Koszuliński

Summary: WSC fails to apply changes if nested editable was focused[Blink/Webkit] WSC fails to apply changes if nested editable was focused

comment:6 Changed 5 years ago by Olek Nowodziński

Status: reviewreview_passed

Rebased both branches on major. An extra commit added to tests.

comment:7 Changed 5 years ago by Piotrek Koszuliński

It's worth including a TC from #11009.

comment:8 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on major with git:e49980f and 1118c18 on tests.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy