Opened 5 years ago

Last modified 5 years ago

#10897 confirmed Bug

IE9/IE10 - No visual indication that a table is selected

Reported by: Teresa Monahan Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM IE9 IE10 Cc: Satya Minnekanti, Irina

Description

To reproduce:

  • Insert a table in the editor in IE9/IE10
  • Click on table in the elements path bar to select the table

Problem: There is no visual indication that the table is selected.

Note that if you use Ctrl+C and Ctrl+V the table is copied and pasted, so it is actually selected. However the user is not aware of this.

In IE8, browser handles are displayed when the table is selected.

This stopped working in IE9/IE10 with git:396c4f0 where w3c DOM APIs were enabled for IE>9 so I am not sure if this is an IE issue or not. Either way it would be good to be able to give the user some visual indication that the table is selected in these browsers.

Change History (8)

comment:1 Changed 5 years ago by Satya Minnekanti

same issue happens when user selects a row or cell in a table by clicking on tr or td in the elements pathbar

comment:2 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.2.2 (GitHub - master)

This is how IE works when there is no data in table. You can't select table or row when there is no data in it.

comment:3 in reply to:  2 Changed 5 years ago by Teresa Monahan

Replying to j.swiderski:

This is how IE works when there is no data in table. You can't select table or row when there is no data in it.

@j.swiderski - There is a visual indication that an empty table is selected in IE9/10 using CKEditor 3.6.x. You can see this at http://rev.ckeditor.com/ckeditor/trunk/7695/_samples/replacebyclass.html. Browser handles are displayed around the table.

comment:4 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: closedreopened

comment:5 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: reopenedclosed

@tmonahan at first i thought that this is because config.disableNativeTableHandles is set to true by default but setting this option to false has no effect.
It turned out this isn't the only problem with native resize in IE and Firefox: #9317, #10252, #10197.

Your ticket seems to be a duplicate of #9317.

comment:6 Changed 5 years ago by Piotrek Koszuliński

I think that this ticket has been incorrectly closed as #9317's duplicate. It's rather a part of a general issue #12123.

comment:7 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: closedreopened

Yes you are right - this issue is part of #12123 and was closed incorrectly.

comment:8 Changed 5 years ago by Jakub Ś

Keywords: IE9 IE10 added
Status: reopenedconfirmed

Problem can be reproduced from CKEditor 4.0.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy