Opened 6 years ago

Closed 5 years ago

Last modified 3 years ago

#10902 closed Bug (wontfix)

ACF is not applied when getting data while in source mode

Reported by: Piotrek Koszuliński Owned by:
Priority: Normal Milestone:
Component: General Version: 4.1 RC
Keywords: Cc: glen.84@…

Change History (7)

comment:1 Changed 5 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 5 years ago by Frederico Caldeira Knabben

Resolution: wontfix
Status: confirmedclosed

This is by design. CKEditor doesn't touch data when posting from source mode.

comment:3 Changed 3 years ago by Jakub Ś

#14801 was marked as duplicate.

comment:4 Changed 3 years ago by darkangel

I need this as well. Is there any way to at least manually trigger the ACF on the source?

comment:5 Changed 3 years ago by darkangel

Cc: glen.84@… added

comment:6 Changed 3 years ago by Jakub Ś

@darkangel - I'm not familiar with any such solution.

For particular scenario mentioned I would either disable Submit button in source mode or when submit button is pressed, I would switch modes and when mode is changed I would submit form manually.

comment:7 Changed 3 years ago by darkangel

Disabling the submit button would be confusing to the user. For now I'm just showing an alert with the message "You may not submit the form while the editor is in source mode", but running the ACF on submit would be a lot better.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy