Opened 6 years ago

Closed 6 years ago

#10927 closed Bug (duplicate)

When ckeditor is inside a jquery UI dialog, richcombo dropdown panels fail when clicked on to close

Reported by: Fireballer Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version:
Keywords: Cc:

Description

It looks like jQuery UI's dialog steals the mousedown event somehow: (tested in Chrome) For example:

<body>
	<div id="dialog">
		<textarea id="input-ck"></textarea>
	</div>
</body>

This fails:

<script>
$(function () {
	$('#dialog').dialog({
		open: function () {
			$('#input-ck').ckeditor();
		},
		width: 1000,
		position: 'center top'
	});
});
</body>

My workaround (but I have to give up draggable and resizable):

<script>
$(function () {
	$('#dialog').dialog({
		open: function () {
			$('#input-ck').ckeditor();
			$('div.ui-dialog.ui-widget.ui-widget-content.ui-corner-all.ui-front').unbind('mousedown');

		},
		width: 1000,
		position: 'center top',
		draggable: false,
		resizable: false
	});
});
</body>

Attachments (1)

ck-combobox-error.jpg (72.3 KB) - added by Fireballer 6 years ago.
Screenshot

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by Fireballer

Attachment: ck-combobox-error.jpg added

Screenshot

comment:1 Changed 6 years ago by Piotrek Koszuliński

Keywords: combobox removed
Status: newpending
Version: 4.3 Beta

Please see http://bugs.jqueryui.com/ticket/4727 - AFAIK you have to register CKEditor's components when opening it in jQ UI dialog. Let us know if it helped.

comment:2 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: pendingclosed

This issue is a duplicate of #10269

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy