Opened 6 years ago

Closed 6 years ago

#10939 closed Bug (fixed)

[FF] Image2: hovering the image causes it to change.

Reported by: Marek Lewandowski Owned by:
Priority: Normal Milestone: CKEditor 4.3
Component: General Version: 4.3 Beta
Keywords: Cc:

Description

since: 4.3

Tested with FF24: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

Hovering the image causes it to change. It looks kinda like it resizes just a little bit, or like it would became sharper.

  1. open any sample with CKEditor (i.e. plugins/image2/samples/image2.html)
  2. hover image with mouse cursor

Attachments (1)

ffhoverbug.mp4 (2.0 MB) - added by Olek Nowodziński 6 years ago.

Change History (9)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Status: newconfirmed

I've seen this too... Unfortunately, seems to be a FF bug. But still Olek could give it a look.

Changed 6 years ago by Olek Nowodziński

Attachment: ffhoverbug.mp4 added

comment:2 Changed 6 years ago by Olek Nowodziński

Without the following in contents.css I'm unable to reproduce the issue:

:not(.ie8) img:hover
{
	opacity: .9;
	filter: alpha(opacity = 90);
}

Yet the funny thing is that it's reproducible for every image with specified dimensions in framed editor. For example:

  1. Use replacebycode.
  2. Set the following HTML:
    <p><img src="http://i.imgur.com/RyPWe66.jpg" style="height:173px; width:124px" /></p>
    <p><img src="http://i.imgur.com/RyPWe66.jpg" style="height:134px; width:168px" /></p>
    
  3. The first image is OK. The second one is flickering.

Tested with the minimal setup:

CKEDITOR.replace( 'editor1', {
	plugins: 'wysiwygarea',
	allowedContent: true
} );

Also see attached screencast​ to find that the issue is random.

comment:3 Changed 6 years ago by Olek Nowodziński

Resolution: wontfix
Status: confirmedclosed

comment:4 Changed 6 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: closedreopened

Why hasn't this issue been reported on Gecko's bug tracker? This is rather important one, because it's very visible. We should also try to find a workaround if Mozilla won't fix it quickly.

Last edited 6 years ago by Piotrek Koszuliński (previous) (diff)

comment:5 Changed 6 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3

comment:6 Changed 6 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3

This issue is already reported: https://bugzilla.mozilla.org/show_bug.cgi?id=714137

Also, we can avoid this image jumping by choosing different width of images (files or in HTML).

comment:7 Changed 6 years ago by Piotrek Koszuliński

Since this bug is appearing randomly, other solution could be to stop using opacity:0.9 for hovered images inside widgets. Widgets have their own hover styles, so we don't need this for image2.

comment:8 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reopenedclosed

Fixed directly on major with git:4986e13.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy