Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10997 closed Bug (duplicate)

Ckeditor for drupal adding media popup not closing

Reported by: Daniele Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0.1
Keywords: Cc:

Description

Hi, on a fresh intall of drupal 7.21 i have installed ckeditor module doenloaded from here:

http://cksource.com/ckeditor-for-drupal/download

When i add a new content on drupal and try to insert for axample an image. When i click ok in the appeared popup it not closing.

If i try to add an url to image, it disappear.

When i try to close with X an error message appear and say something like "The changes are not applied"

Change History (5)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: Popup media insert removed
Status: newpending

You have downloaded CKEditor drupal module which needs to be configured according to - http://docs.cksource.com/CKEditor_for_Drupal. Have you done that?

Could you perhaps send me test access to your drupal (my email j.swiderski@…)? I have tried what you have described but everything has been working as expected. Have I missed anything?

Please provide step by step scenario explaining how to reproduce the problem and if possible please provide test access to your application.

comment:2 Changed 6 years ago by Daniele

Yes, ive installed ckeditor bundle for drupal. And configured it as above.

The step are:

1 Install drupal 2 install ckeditor module and enable 3 configure user access to application 4 create new content 5 with ckeditor click on image icon, upload to server with ckfinder and select it 6 Click ok, the popup can't close if i click X button to close it a waning message appear sang something about changes not applied.

Sometimes the image appear in the background everytime that i click ok but the popup can't close.

I i try to edit the images after and for example try to add an url, it disappear.

Ok i've send credential to your email.

Thanks

Last edited 6 years ago by Daniele (previous) (diff)

comment:3 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: pendingclosed

Thanks for credentials. I have checked this issue on Chrome, FF and they have given me the answer. This issue is a duplicate of #9305.

You are using CKE and CKF in cross domain. This is what Chrome has returned:

"Blocked a frame with origin "http://meconiotech.altervista.org" from accessing a frame with origin "http://maschioalfa.it". Protocols, domains, and ports must match. "

This is either accidental or done on purpose configuration but one thing is for sure it should not take place.

You can't use JavaScript in cross domain. Browsers won't allow it. You need to change it. Please note the only thing editor can do here is preventing reaching the parent frame as it won't bypass cross domain restriction.

comment:4 Changed 6 years ago by Daniele

Thanks for the reply, there is something that i can do for resolve?

comment:5 Changed 6 years ago by Jakub Ś

Please get familiar with 'cross domain' term. It will give you idea what it is and what to do.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy