Opened 6 years ago

Closed 6 years ago

#11002 closed New Feature (fixed)

Disable widget drag handlers

Reported by: xmo Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.3
Component: UI : Widgets Version:
Keywords: Cc:

Description

Is there or could there be an option to not setup draghandlers on widgets? We don't need them in our system, we're currently hiding them in CSS, but still paying the setup cost (for my demo page holding 46 widgets, that's about 150ms: removing setupDragHandler and positionDragHandler lowers the editor initialization time from ~1400ms to ~1250ms)

Change History (5)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3
Status: newconfirmed

Actually, I was planning to add such option. I'm aware that it's not always necessary and may be heavy, because it isn't implemented in very optimum way (#11001).

comment:2 Changed 6 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:3 Changed 6 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed t/11002 on dev and tests.

comment:4 Changed 6 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:5 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on major with git:ca537ae on dev and cfd4230 on tests.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy