Opened 12 years ago

Closed 11 years ago

#1101 closed Bug (wontfix)

Pasted links have forced font color in IE

Reported by: Lukasz Frankowski Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4.3
Keywords: IE CantFix Cc:

Description

When I copy and paste text with link in IE6/IE7 (from fckeditor text to fckeditor text) the:

<a href="XXX">YYY</a>

becomes:

<a href="XXX"><font color="#0000ff">YYY</font></a>

Change History (4)

comment:1 Changed 12 years ago by Lukasz Frankowski

I've checked in fckeditor demo and the problem is not present there. It only occurs, when I have my own styles assigned to fckeditor area, especially the link styles (setting the link color?). In this case this it is:

.myfckarea a { 
  color: #8c301f !important;
  text-decoration: underline !important;
}
.myfckarea a:hover { 
	color: #ce301f !important;
}

comment:2 Changed 11 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added

Hi!

I've changed editor area css to your configuration and everything seems to work fine in IE.

Let us know if the bug still occurs in the newest version 2.5.1.

Thanks!

comment:3 Changed 11 years ago by Lukasz Frankowski

Hi, it'll be time-consuming and difficult to migrate to 2.5.1 for us now, because we tightly integrated 2.4.3. But if it happens I'll notify you.

But you can check with your browser if the problem is present in 2.4.3 (or maybe no - problem with our browser version?). To do it please enter here, click on the login link (at bottom-right), use password 'demo' and then click on any active area. You can check if the bug is present by putting a link somewhere and then marking the text with link and copy-paste it to the same fckeditor area. I did it in IE 7.05730.11

comment:4 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Keywords: IE CantFix added; Pending WorksForMe removed
Resolution: wontfix
Status: newclosed

Yes, the problem is present in your demo using IE, but that's because it's an internal IE behavior when pasting some content, Firefox works fine, and the only way to fix the problem in IE is to use the Paste from word dialog so the content can be cleaned up before pasting.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy