Opened 5 years ago

Closed 5 years ago

#11066 closed Bug (fixed)

Widget's private parts don't use CSS reset

Reported by: Piotrek Koszuliński Owned by: Piotr Jasiun
Priority: Normal Milestone: CKEditor 4.3
Component: UI : Widgets Version: 4.3 Beta
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

Based on: http://ckeditor.com/forums/Support/Widgets-break-when-muliple-inline-editor-instances-on-one-page

Drag handler and widget mask requires very precise styles applied to them. Currently, since we don't use any CSS reset for them, it's very probable that page's styles will break them.

Change History (8)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Description: modified (diff)

comment:2 Changed 5 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: newassigned

comment:3 Changed 5 years ago by Piotr Jasiun

Status: assignedreview

I've added .cke_reset class to widgets mask and handler, what should solve the problem. I also added default values of position and transition in .cke_reset style.

The problem is we have not enough information to reproduce exactly the same case and I have no idea why the issue appears only with multiple editors, but this fixes should be solution.

Changes in t/11066.

comment:4 Changed 5 years ago by Piotr Jasiun

Status: reviewassigned

Tests needs fixes after this change.

comment:5 Changed 5 years ago by Piotr Jasiun

Status: assignedreview

Tests fixed in t/11066.

comment:6 Changed 5 years ago by Olek Nowodziński

Rebased branches on latest major.

comment:7 Changed 5 years ago by Olek Nowodziński

Status: reviewreview_passed

Pushed a couple of commits to dev and tests.

A single remark there: transition: none; is enough to disable transitions. There's no need for transition: all 0 ease 0;.

comment:8 Changed 5 years ago by Piotr Jasiun

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy