Opened 6 years ago

Closed 4 years ago

#11072 closed Bug (duplicate)

Merge cells doesn't work in FF when replaced textarea with inline editor

Reported by: Ales Seifert Owned by:
Priority: Normal Milestone:
Component: Core : Tables Version: 4.0 Beta
Keywords: Firefox Cc: richard@…

Description

Tested in FF24 on

http://nightly.ckeditor.com/13-11-03-07-05/full/samples/inlinetextarea.html

when selected few cells in one row and selected merge cells some JS exception is logged on console.

Same works OK in Chrome, not tested anywhere else.

Bug found from 4.0.1 (older not tested) to 4.3 beta.

Attachments (1)

table_grabber_error.jpg (396.1 KB) - added by Richard Thiel 5 years ago.
This happens, when I mark 2 or multiple cells from a table.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 years ago by Jakub Ś

Keywords: Firefox table merge cells removed
Status: newpending
Version: 4.2.2

I have checked this issue in latest Firefox 30 and latest CKEditor 4.4.2 full and standard packages. No such issue have occurred.

@alesak are you still able to reproduce this problem? Perhaps you are using third-party plugins, not created by CKSource team, which cause this problem?

comment:2 Changed 5 years ago by Richard Thiel

Cc: richard@… added

Just found this ticket. Error is still active.

Other reference of this error I found - http://dev.ckeditor.com/ticket/9770

@j.swiderski: in the full and standard Sample the error don´t occur. Only in the INLINE-Version of the Editor the error occurs.

Error I get in the sample (http://ckeditor.com/demo#inline): TypeError: a.getDocument is not a function ckeditor.js:858

Error I get in my own Project: TypeError: cell.getDocument is not a function plugin.js:402

Same problem, just not minified code ;)

Browser: Firefox 31.0 OS: Windows 8

I attach an Screenshot of the Inline-Sample with some other error that occurs but I think its linked to this error.

Changed 5 years ago by Richard Thiel

Attachment: table_grabber_error.jpg added

This happens, when I mark 2 or multiple cells from a table.

comment:3 Changed 5 years ago by Jonathan

We are still seeing this in Firefox 30 with the Div Editing Area plugin which I assume is what others are referring to when they see this with inline editing. Another manifestation is that you cannot select multiple cells at a time and change the properties for them with the right-click menu. So if I want to change the background color of a row, I would have to change the background color for each cell individually.

comment:4 Changed 5 years ago by Jakub Ś

Thank you for detailed explanation. Problem can be reproduced from CKEditor 4.0 beta only in Firefox.

  1. Open inlinebycode sample
  2. Insert 4x5 table
  3. Select first and second cell in first row.
  4. Right click on first cell and select Cell -> Merge Cells

Result: Error is thrown.

Message: cell.getDocument is not a function
Code: var docInner = cell.getDocument()
URI: /ckeditor-dev/plugins/tabletools/plugin.js
Line : 402

comment:5 Changed 4 years ago by Jakub Ś

Keywords: Firefox added
Status: pendingconfirmed
Version: 4.0 Beta

comment:6 Changed 4 years ago by Wiktor Walc

Resolution: duplicate
Status: confirmedclosed

Duplicate of #10745.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy