Opened 5 years ago

Closed 5 years ago

#11088 closed Bug (duplicate)

[IE8] image2 widget paste throws an exception on paste undo

Reported by: Marek Lewandowski Owned by: Marek Lewandowski
Priority: Normal Milestone:
Component: General Version: 4.3
Keywords: Cc:

Description

since: 4.3 until major

Issue does not occur with placeholder plugin. Couldn't test if it occurs with matjax or not.

  1. open sample with image2 plugin ( i.e. /plugins/image2/samples/image2.html )
  2. copy one of widgets
  3. paste
  4. press ctrl+z (undo)

Expected result:
Widget should be removed.

Current result:
Exception is being thrown:

'blur' is null or not an object  focusmanager.js, line 221 character 4

additional info:

  1. I was able to reproduce it somehow when i was playing with widgets using keyboard only, however i couldn't write tc for it so far. But it was exactly the same exception.

Change History (3)

comment:1 Changed 5 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: newreview

I've added quickfix proposition for that issue in t/11088

comment:2 Changed 5 years ago by Marek Lewandowski

Milestone: CKEditor 4.3

comment:3 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3
Resolution: duplicate
Status: reviewclosed

Will be fixed in #10887.

The reason of error was:

When you press CTRL+C widget's copy is made in copybin. Widget system sees that new widget HTML and initializes widget on it. Then after a 100ms that widget is gone, because we remove copybin. Widget system destroys the widget, removes its custom data and when you undo, that original (copied) widget has no custom data any more.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy