Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11105 closed Bug (invalid)

CKEditor edit-mode is not working in Linux version of Google Chrome (Chromium)

Reported by: Wojciech Owned by:
Priority: Normal Milestone:
Component: Core : Editable Version: 4.3
Keywords: Cc:

Description

OS: Debian 7.1 Wheezy (updated) Browser: Chromium Version 30.0.1599.101 Debian jessie/sid (227552) Test case page: http://ckeditor.com/ckeditor_4.3_beta/samples/jquery.html

I'm clicking inside editable area, and then i receive the following error in Chrome console on every time when I click:

Uncaught TypeError: Cannot read property 'type' of undefined

Screenshot: http://minus.com/lbowKEekBEBOH9

Attachments (1)

Selection_055.png (156.8 KB) - added by Wojciech 6 years ago.
Screenshot

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by Wojciech

Attachment: Selection_055.png added

Screenshot

comment:1 Changed 6 years ago by Piotrek Koszuliński

Status: newpending

I've got a Chrome Version 30.0.1599.114 on Ubuntu 12.04 and I don't see any errors.

comment:2 Changed 6 years ago by Jakub Ś

  • Please don't forget to clear your browsers cache before you check this.
  • Does your chromium have any plugins installed? Could you try disabling them, clearing cache and see if it works then?

comment:3 in reply to:  1 Changed 6 years ago by Wojciech

Replying to Reinmar:

I've got a Chrome Version 30.0.1599.114 on Ubuntu 12.04 and I don't see any errors.

## When are those errors thrown?
When I click on the text (for example) inside ckeditor editable area.

## Do you see them on ​https://github.com/ckeditor/ckeditor-dev/tree/major too?
Yes. But error is thrown in selection.js at line 993.

## I think that the error may be thrown in ​https://github.com/ckeditor/ckeditor-dev/blob/major/core/selection.js#L993, but still, I'm not able to reproduce this issue.
You're right. Here is the screenshot (ckeditor-dev-major):
http://minus.com/lzzBqtWlBXBzf

Last edited 6 years ago by Wojciech (previous) (diff)

comment:4 in reply to:  2 Changed 6 years ago by Wojciech

Replying to j.swiderski:

  • Please don't forget to clear your browsers cache before you check this.
  • Does your chromium have any plugins installed? Could you try disabling them, clearing cache and see if it works then?

## Please don't forget to clear your browsers cache before you check this.
## Does your chromium have any plugins installed? Could you try disabling them, clearing cache and see if it works then?
Ok, I forget about extensions. Now I know what is causing this problem - it is "Better Pop Up Blocker" addon (v2.1.6).
I think it is good idea to fix this. Other people may also have this extension but are not necessarily programmers.

comment:5 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

Thanks for info. We cannot assure compatibility with every addon. I see on this addon's page that it breaks also other systems like e.g. Facebook.

comment:6 in reply to:  5 Changed 6 years ago by Wojciech

Replying to Reinmar:

Thanks for info. We cannot assure compatibility with every addon. I see on this addon's page that it breaks also other systems like e.g. Facebook.

Could you detect the installed add-ons, and display a warning message when it is installed 'Better popup blocker' ? This will be useful information for users that this addition makes the "CKEditor" does not work. This issue includes probably all WebKit browsers.

comment:7 Changed 6 years ago by Piotrek Koszuliński

We cannot maintain a list of incompatibility browsers' addons. How would we test all them and their combinations? It's simply impossible. I don't know any software vendor which does that.

comment:8 in reply to:  7 Changed 6 years ago by Wojciech

Replying to Reinmar:

We cannot maintain a list of incompatibility browsers' addons. How would we test all them and their combinations? It's simply impossible. I don't know any software vendor which does that.

http://stackoverflow.com/questions/6293498/check-whether-user-has-a-chrome-extension-installed?answertab=votes#tab-top You can temporarly write hardcoded detection for only 'Better popup blocker'. What do you think about it?

comment:9 Changed 6 years ago by Jakub Ś

You can temporarly write hardcoded detection for only 'Better popup blocker'. What do you think about it?

I'm sorry but I don't see this as good idea. List should definitely not be hardcoded but in some external file. The problem is anyone can create extension which may be incompatibile with other software. Soon after this extension other users may ask to add other ones, some extensions might get fixed after our release and we would get bug reports from users claiming that editor displays invalid warnings about working extensions.

I'm afraid this would be a nightmare feature thus we simply don't want to go that way.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy