Opened 6 years ago

Closed 6 years ago

#11142 closed Bug (fixed)

Exception is being thrown on context menu in bulletlist

Reported by: Marek Lewandowski Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.3
Component: General Version: 4.3
Keywords: Cc:

Description (last modified by Marek Lewandowski)

since: 4.3 until major

Touches opera/chrome (dont know about the others). So far i have reproduced it on Windows only, Olek says that he can't repro it with Opera+OSX

  1. open /samples/inlineall.html

( there is a bullet list starting with string "Ut sagittis, nunc liber" )

  1. click in order to position caret in following place (but does not have to be exatly the same):

Ut sagittis|, nunc liber

  1. Right click mouse in the same place (to show context menu)

(if you are on chorme: )

  1. now that context menu is open click LMB once again
  2. ... and click RMB once more : )

Current result:

Uncaught TypeError: Cannot call method 'getAttribute' of null

is being thown

Change History (5)

comment:1 Changed 6 years ago by Marek Lewandowski

Description: modified (diff)

comment:2 Changed 6 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: newassigned

comment:3 Changed 6 years ago by Olek Nowodziński

Status: assignedreview

Pushed fix to t/11142.

The problem was that Magicline retrieved Contextmenu panel internals and tried to search for matching elements there.

comment:4 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_passed

comment:5 Changed 6 years ago by Olek Nowodziński

Resolution: fixed
Status: review_passedclosed

Merged fix into major git:7d019b5.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy