Opened 6 years ago

Closed 6 years ago

#11148 closed Bug (invalid)

[IE8] Crash when widget copy & paste

Reported by: Olek Nowodziński Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 4.3
Keywords: Cc:

Description (last modified by Olek Nowodziński)

I spotted some crashes when running tests in IE8. For example, the crashing test is "test pasting widget which was copied (d&d) when its nested editable was focused" in dt/plugins/widget/nestededitables.html

It doesn't matter whether that test is standalone or ran along with others.

Also there's manual TC (major):

  1. Open http://ckeditor4.t/ckeditor/plugins/image2/samples/image2.html
  2. Focus the widget.
  3. C-c
  4. Without changing/touching anything C-v (do it fast, right after C-c)
  5. Crash.

See attached video.

IE version: 8.0.6001 (VM from ModernIE).

Attachments (1)

ie8_widget_copy_paste_crash.mp4 (163.5 KB) - added by Olek Nowodziński 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by Olek Nowodziński

comment:1 Changed 6 years ago by Olek Nowodziński

Description: modified (diff)

comment:2 Changed 6 years ago by Piotrek Koszuliński

No crash on my IE8. Both tests and manual tc are passing.

It's the save IE version, but normal Win XP (not from ModernIE).

comment:3 Changed 6 years ago by Jakub Ś

Status: newpending

I had no crash either with Ie8 and latest major.

comment:4 Changed 6 years ago by Piotr Jasiun

Everything is fine for me.

comment:5 Changed 6 years ago by Wiktor Walc

I cannot reproduce it either:

IE 8.0.6001.18702 @ XP Version 5.1.2600 Service Pack 3 Build 2600

comment:6 Changed 6 years ago by Wiktor Walc

However, there is one edge case, which does not result in a browser crash, there is just a JS error:

  • Select a widget, wait few seconds
  • Press very quickly Ctrl+C and Ctrl+V
  • Result:
    Message: Invalid argument.
    Line: 1772
    Char: 5
    Code: 0
    URI: ckeditor-dev/core/selection.js
    
Last edited 6 years ago by Wiktor Walc (previous) (diff)

comment:7 Changed 6 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3
Resolution: invalid
Status: pendingclosed

Closing. Perhaps tomorrow it will be gone on Olek's OS too :D

Regarding comment:6 - edge case and most likely no one will ever report it.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy