Opened 11 years ago

Closed 11 years ago

#1116 closed Bug (fixed)

Anchors do not work (and resolution proposal)

Reported by: barns Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Confirmed Cc:

Description

When creating an anchor in FCK, and then displaying corresponding wikitext, I get an empty link:

[[]]

Mediwiki recommendation for creating manual anchors is to do:

<span id="anchor_name"></span>.

See http://meta.wikimedia.org/wiki/Help:Link#Anchors for details

Change History (2)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added

Actually it is a more complicated issue. When using { [[#anchor_name]] the editor changes the name to [[|#Sec1]] Creating manual anchors resolves the problem partially. e.g. the section is called "Science". You can use this code: == <span id="Science"> Science </span> == for naming the anchor and than [[#Science|Go to Science section]] for linking to it. However problem still remains because when you try to edit the link the name of the section dissapers so you have something like this: [[|Go to Science section]]

comment:2 Changed 11 years ago by Wiktor Walc

Resolution: fixed
Status: newclosed

It looks like it works. Probably it has been fixed here: #1690.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy