Opened 5 years ago

Closed 5 years ago

#11178 closed Bug (fixed)

[IE] Error thrown in htmlDataProcessor test

Reported by: Piotrek Koszuliński Owned by: Marek Lewandowski
Priority: Normal Milestone: CKEditor 4.3.1
Component: General Version:
Keywords: Cc:

Description


Attachments (2)

1.html (717 bytes) - added by Marek Lewandowski 5 years ago.
TC
selchange.html (855 bytes) - added by Olek Nowodziński 5 years ago.
Yet another sample to reproduce

Download all attachments as: .zip

Change History (10)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:2 Changed 5 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:3 Changed 5 years ago by Marek Lewandowski

Owner: changed from Piotr Jasiun to Marek Lewandowski

comment:4 Changed 5 years ago by Marek Lewandowski

So far i got following informations for this issue:

its caused by test avoid having inline event handlers executed TC.

The reason leading to an exception is following (is quite nice sequence):

  • having config enterMode = CKEDITOR.ENTER_BR
  • calling this.editor.focus()
  • calling editor.setData

Error is originated from wysiwygarea\plugin.js:168 which is invoked selectionchange

affected browsers: ie10, ie11 not affected: ie9

Last edited 5 years ago by Marek Lewandowski (previous) (diff)

comment:5 Changed 5 years ago by Piotrek Koszuliński

From what I see that doc#selectionchange event during which selection is broken is fired after editable is destroyed, so using editable#attachListener helps. However, I'd be good to know the exact moment when it happens - what code causes selectionchange.

Last edited 5 years ago by Piotrek Koszuliński (previous) (diff)

comment:6 Changed 5 years ago by Marek Lewandowski

Status: assignedreview

I've applied in t/11178 fix suggested by PK. It prevents from exception, and still provides quickfix originally implemented by changed code. After some testing I was not able to precisely locate real source of this issue.

I've separated essential code which leads to exception in a TC but i dont think if it's needed since it can't be fit into an assertion (so CKTester can't display it as failure), since it happens in event listener. But still i will attach this TC to the ticket.

Changed 5 years ago by Marek Lewandowski

Attachment: 1.html added

TC

Changed 5 years ago by Olek Nowodziński

Attachment: selchange.html added

Yet another sample to reproduce

comment:7 Changed 5 years ago by Olek Nowodziński

Status: reviewreview_passed

I gave up investigating the origin of that bug since it's just a waste of time. The only conclusion is that debugger in IE is useless.

I attached another sample to reproduce the issue without tester.

comment:8 Changed 5 years ago by Marek Lewandowski

Resolution: fixed
Status: review_passedclosed

Yea it was pretty time consuming. Fixed with git:73b32732d at dev.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy