Opened 5 years ago

Closed 5 years ago

#11195 closed Bug (duplicate)

Dropdown "Styles" isn't closing on unfocus in jquery Dialog

Reported by: igorm Owned by:
Priority: Normal Milestone:
Component: General Version: 4.3
Keywords: Cc:

Description

To reproduce:

  • open http://jsfiddle.net/tu4w2/2/
  • on the "Result" panel click "Create Editor"
  • in CKEditor on the toolbar panel click on the word "Styles"
  • click on the word "Styles"
  • small styles popup will stay, javascript error will be logged

Please, please fix it. With this bug CKEditor is not usable in jquery Dialogs.

Attachments (2)

result.JPG (34.6 KB) - added by igorm 5 years ago.
ckeditor-jdialog-bug.zip (1.5 MB) - added by igorm 5 years ago.
HTML project that shows the problem

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by igorm

Attachment: result.JPG added

comment:1 Changed 5 years ago by Piotrek Koszuliński

Status: newpending

The error is thrown earlier and is caused by bug in your fiddle.

Regarding the issue - have you reproduced it also on normal page? JSFiddle is very specific environment and breaks some things in CKEditor. This may be one of them.

comment:2 in reply to:  1 Changed 5 years ago by igorm

Replying to Reinmar:

Regarding the issue - have you reproduced it also on normal page?

I attached the simple html project (ckeditor-jdialog-bug.zip) which shows the issue. It happens on any browser I tested, with any drop down on the panel.

Changed 5 years ago by igorm

Attachment: ckeditor-jdialog-bug.zip added

HTML project that shows the problem

comment:3 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: pendingclosed

DUP of #10269.

Please see that ticket for possible workarounds. There was also fix for jQuery mentioned.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy