Opened 5 years ago

Closed 4 years ago

#11218 closed Bug (duplicate)

Bug in bbcode plugin

Reported by: don Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version:
Keywords: Cc:

Description

Hi, I found a bug in bbcode plugin.

I tried to copy and paste a word document into CKEditor. The first line of the document is the title. After paste into CKEditor, I tried to delete the title part. But in the source, the bbcode always has "=13px"

Please advice! Thanks.

Attachments (2)

sample.docx (514.9 KB) - added by don 5 years ago.
Word Sample
2014-05-07_1405.swf (1.4 MB) - added by Jakub Ś 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by don

Attachment: sample.docx added

Word Sample

comment:1 Changed 5 years ago by Frederico Caldeira Knabben

Component: GeneralPlugin : Paste from Word

comment:2 Changed 5 years ago by Jakub Ś

Status: newconfirmed

There are two issues I see here:

  1. MS Word document gets pasted as HTML and not as code that can be understood by BBCode plugin
  2. When you remove Title and switch to source ="13" will be visible there (Please see video)

I think second issue might be omitted when first one is fixed.


@dodoflying issue with paste from word can sort of worked around when using forcePasteAsPlainText : true configuration option in editor configuration.
I'm saying sort of because then everything (even images) are pasted as plain text.


@dodoflying please also note that BBcode is proposal of BBCode implementation. There is no standard for it thus all implementations can differ.
If you have idea for fixing this issue or have found another issue and you know how it can be fixed, you are welcome to create a pull request: https://help.github.com/articles/creating-a-pull-request

Changed 5 years ago by Jakub Ś

Attachment: 2014-05-07_1405.swf added

comment:3 Changed 4 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

This is a duplicate of #10591.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy