Opened 5 years ago

Closed 5 years ago

#11224 closed Bug (duplicate)

transparentImageData URI in widget plugin is escaped

Reported by: Alfonso Martínez de Lizarrondo Owned by:
Priority: Normal Milestone:
Component: UI : Widgets Version: 4.3
Keywords: Cc:

Description

Currently it's

  var transparentImageData = 'data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D',

but it should be

  var transparentImageData = 'data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==',

(just replace %3D with =)

Change History (2)

comment:1 Changed 5 years ago by Alfonso Martínez de Lizarrondo

This is strange, I got a mail asking for further information, but I don't see the comment here.

#11225 is an enhancement not directly related to this bug.

The problem is that it's just incorrect, you can test it by trying to decode the image:

window.atob('data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw%3D%3D'.split(',')[1])

vs

window.atob('data:image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw=='.split(',')[1])

comment:2 Changed 5 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: newclosed

I removed my previous comment, because I figured out the answer few secs after posting it :D.

I included patch for this in #11225.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy