Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11284 closed Bug (fixed)

[IE8] Modernizr 2.5.x causes error when opening link dialog

Reported by: Jason Woodward Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IE8 Cc:

Description (last modified by Piotrek Koszuliński)

Steps to reproduce:

  • Fire up IE8 on Windows XP. I used the one available from http://modern.ie
  • Open a page which loads Modernizr 2.5.x (we tested 2.5.3).
  • Click in the text.
  • Click the link button.
Message: Invalid argument.
Line: 448
Char: 302
Code: 0
URI: http://ckeditor.com/apps/ckeditor/4.3/ckeditor.js?mxj8dy

After upgrading Modernizr everything works fine.

Attachments (9)

IE8_-_WinXP_-_Parallels_Desktop.png (141.3 KB) - added by Jason Woodward 5 years ago.
Screenshot of javascript error popup dialog
Selection_146.png (246.2 KB) - added by Piotrek Koszuliński 5 years ago.
Selection_144.png (322.7 KB) - added by Piotrek Koszuliński 5 years ago.
Selection_147.png (167.4 KB) - added by Piotrek Koszuliński 5 years ago.
Selection_148.png (75.1 KB) - added by Piotrek Koszuliński 5 years ago.
Selection_149.png (19.5 KB) - added by Piotrek Koszuliński 5 years ago.
Selection_150.png (82.9 KB) - added by Piotrek Koszuliński 5 years ago.
Selection_151.png (18.4 KB) - added by Piotrek Koszuliński 5 years ago.
Selection_152.png (43.7 KB) - added by Piotrek Koszuliński 5 years ago.

Download all attachments as: .zip

Change History (19)

Changed 5 years ago by Jason Woodward

Screenshot of javascript error popup dialog

comment:1 Changed 5 years ago by Dennis1993

update your stone-age system. You don't drink 10 years old milk!

comment:2 in reply to:  1 Changed 5 years ago by Jason Woodward

Replying to Dennis1993:

update your stone-age system. You don't drink 10 years old milk!

I'm guessing you're making a joke here, but in case you're not, check out the list of "A-Grade" supported browsers at http://docs.ckeditor.com/#!/guide/dev_browsers which states IE8 is supported by CKEditor at the same level as more modern browsers.

Perhaps this should be a documentation bug then, with the support list being updated if the policy has changed since http://docs.ckeditor.com/#!/guide/dev_browsers was last updated?

Changed 5 years ago by Piotrek Koszuliński

Attachment: Selection_146.png added

Changed 5 years ago by Piotrek Koszuliński

Attachment: Selection_144.png added

comment:3 Changed 5 years ago by Piotrek Koszuliński

Status: newconfirmed

Well... yes, error is thrown (you can ignore my screenshots). IE8 is supported and every CKEDITOR release is tested on every supported browser. But on the other hand it's impossible to test everything and fix all bugs. For example, I cannot reproduce this bug locally, so perhaps that's why we missed it.

Last edited 5 years ago by Piotrek Koszuliński (previous) (diff)

comment:4 Changed 5 years ago by Piotrek Koszuliński

Component: UI : Floating PanelGeneral
Version: 4.3

Changed 5 years ago by Piotrek Koszuliński

Attachment: Selection_147.png added

Changed 5 years ago by Piotrek Koszuliński

Attachment: Selection_148.png added

Changed 5 years ago by Piotrek Koszuliński

Attachment: Selection_149.png added

comment:5 Changed 5 years ago by Piotrek Koszuliński

Couldn't reproduce this locally, even with filebrowser enabled:

Error thrown on http://ckeditor.com/demo#inline. To reproduce it's enough to focus any editor and click link button:

Because of error dialog initialization is not finished (that fieldset should be hidden):

comment:6 Changed 5 years ago by Jakub Ś

I only got this error on Demo page but not in my local build.

@woodwardjd could you please download editor full package put it on your server and see if you get same error?
This can be Demo specific error that can be caused by e.g. some third-party script and we call those a lot.

comment:7 Changed 5 years ago by Piotrek Koszuliński

This error is ridiculous. IE fails on simple:

document.createElement( 'select' ).add( document.createElement( 'option' )

On ckeditor.com/demo#inline:

Locally:

Last edited 5 years ago by Piotrek Koszuliński (previous) (diff)

Changed 5 years ago by Piotrek Koszuliński

Attachment: Selection_150.png added

Changed 5 years ago by Piotrek Koszuliński

Attachment: Selection_151.png added

Changed 5 years ago by Piotrek Koszuliński

Attachment: Selection_152.png added

comment:8 Changed 5 years ago by Jason Woodward

Thanks for checking this out. It works fine on a dummy installation http://woodwardjd.github.io/cktest/

It is failing in an internal application, but since it failed on the ckeditor.com site I decided to submit with that in the bug report. I will work to isolate the configuration settings and other various bits of JS under which these errors are occurring, but it'll take me a few days.

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0)
Timestamp: Mon, 9 Dec 2013 19:40:15 UTC


Message: Invalid argument.
Line: 480
Char: 302
Code: 0
URI: http://webeditor-sha-main-jdw5.test.shawebtest.cornell.edu/enki_editor/ckeditor/ckeditor.js

comment:9 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

We found a reason. The bug was caused by Modernizr 2.5.3. We updated it to 2.7.1 and the error does not pop out.

comment:10 Changed 5 years ago by Piotrek Koszuliński

Description: modified (diff)
Summary: IE8 / XP invalid argument javascript error[IE8] Modernizr 2.5.x causes error when opening link dialog
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy