Opened 5 years ago

Closed 5 years ago

#11330 closed New Feature (duplicate)

Style Type - Dropdown, multiple elements selector

Reported by: santaclaus21 Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version:
Keywords: Cc:

Description

I would like to redefine style list (dropdown) to make "Color 1" ~= "class: gray" for any elements.

According to docs: http://docs.cksource.com/CKEditor_3.x/Developers_Guide/Styles#Style_Types

I think that I shuld retype definition for all tags, eg.:

{ name: 'Color 1', element: 'span', attributes: { 'class': 'gray' } },
{ name: 'Color 1', element: 'p', attributes: { 'class': 'gray' } },
{ name: 'Color 1', element: 'h1', attributes: { 'class': 'gray' } },
{ name: 'Color 1', element: 'h2', attributes: { 'class': 'gray' } },
{ name: 'Color 1', element: 'h3', attributes: { 'class': 'gray' } },
{ name: 'Color 1', element: 'li', attributes: { 'class': 'gray' } },
...

So maybe I'm wrong, but it's not possibe (?) to use element selector like 'span,p,h1,h2' or '*'.

I will be realy helpfull.

Change History (2)

comment:1 Changed 5 years ago by santaclaus21

Summary: Style Type - Dropdown, multiple definition for elementStyle Type - Dropdown, multiple elements selector

comment:2 Changed 5 years ago by Jakub Ś

Keywords: styles css my_style cascade removed
Resolution: duplicate
Status: newclosed
Version: 4.3.1

This can be considered duplicate of #5980.

Wildcard styles aren't possible because styles have to be visually presented in styles dropdown.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy