Opened 5 years ago

Closed 5 years ago

#11345 closed Bug (duplicate)

ckeditor 4.3.1 does not version image/image references in css

Reported by: Sudhindra Rao Owned by:
Priority: Normal Milestone:
Component: General Version: 4.3.1
Keywords: Cc:

Description

editor.css has references to images as

.cke_buttonbold_icon{

background-image: url(icon.png);

....... }

Could be caused by this line in plugin.js

iconPath = this.path + 'images/' + ( env.hidpi ? 'hidpi/' : ) + 'icon.png';

Due to this, when we use ckeditor with amazon CDN we see old icon.png(which has a different length sprite and cause the images to show up broken).

ckeditor does allow timestamping or version of other assets (js and css files). This might need to be replicated for images as well.

Currently we are not able to upgrade to 4.3.1 due to this issue.

Change History (1)

comment:1 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

DUP of #10685.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy