Opened 5 years ago

Closed 5 years ago

#11390 closed Bug (fixed)

XML plugin doesn't support IE >= 10

Reported by: Alfonso Martínez de Lizarrondo Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.3.3
Component: General Version: 3.0
Keywords: Cc:

Description

The required changes were done in CKFinder long ago and could easily be applied here also.

(I've set the version as 3.0, but I don't know exactly the first version that supported IE10)

Change History (7)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Status: newconfirmed

Seems that constructor works, but not methods.

comment:2 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3.3

I pushed t/11390 with patch ported from CKF. We need tests for it (all XML's methods miss tests).

comment:3 Changed 5 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:4 Changed 5 years ago by Piotrek Koszuliński

Owner: changed from Piotr Jasiun to Piotrek Koszuliński

comment:5 Changed 5 years ago by Piotrek Koszuliński

Status: assignedreview

I pushed t/11390 with basic tests.

It turned out that patch I pushed previously wasn't complete, because it didn't work on IE9+. The reason was that XML plugin still used DOMParser which doesn't have support for XPath on these browsers. I pushed a second commit which changes the feature detection order to promote ActiveXObject which on IEs has support for XPath.

comment:6 Changed 5 years ago by Piotr Jasiun

Status: reviewreview_passed

I rebased both branches and pushed small commit with docs fix. Apart from this everything is fine.

comment:7 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on master with git:de36349 on dev and 691da97 on tests.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy