Opened 6 years ago

Last modified 6 years ago

#11495 confirmed Bug

CKEDITOR.ui.dialog.select size option doesn't work due to css

Reported by: eugene88 Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 4.0
Keywords: Cc:

Description

CKEDITOR.ui.dialog.select size option doesn't work due to css.

select.cke_dialog_ui_input_select {
	height: 24px;
	line-height: 24px;
	background-color: #FFF;
	border: 1px solid #C9CCCF;
	border-top-color: #AEB3B9;
	padding: 2px 6px;
	outline: none;
	-moz-border-radius: 3px;
	-webkit-border-radius: 3px;
	border-radius: 3px;
	-moz-box-shadow: 0 1px 2px rgba(0,0,0,.15) inset;
	-webkit-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.15) inset;
	box-shadow: 0 1px 2px rgba(0, 0, 0, 0.15) inset;
}

height parameter is limiting select area.

Change History (7)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Status: newpending

What do you mean by "does not work"?

comment:2 Changed 6 years ago by Piotrek Koszuliński

Version: 4.3.1

comment:3 in reply to:  1 Changed 6 years ago by eugene88

Replying to Reinmar:

What do you mean by "does not work"?


If you one sets size option for select element then it isn't displayed properly. I assume, that this is due to height property in class discribed above. Should I attache a screenshot?

comment:4 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

I don't see it as an error. For single selection selects, size attribute is 1 and we have set some styles for this default configuration when creating CKE skin.

Now, if you are trying to overwrite some of default CKEditor styles, you should do this properly. You have attached size attribute for select element but you should also add heigh:auto; to its styles attribute or modify select.cke_dialog_ui_input_select and change height:24px; to height:auto;.

comment:5 in reply to:  4 Changed 6 years ago by eugene88

Replying to j.swiderski:

I don't see it as an error. For single selection selects, size attribute is 1 and we have set some styles for this default configuration when creating CKE skin.


But what if size is more than single row(size=1)? Should plugin author due to larger amout of visible rows overwrite default style for select element? Seems a bit incorrect, no? Either styles should be predefined, or in default style there should be height:auto;?

Now, if you are trying to overwrite some of default CKEditor styles, you should do this properly. You have attached size attribute for select element but you should also add heigh:auto; to its styles attribute or modify select.cke_dialog_ui_input_select and change height:24px; to height:auto;.


It(size attribute) wasn't attached manually. As far as I see it is available in Api http://docs.ckeditor.com/#!/api/CKEDITOR.dialog.definition.select. Seems only logical, that if it can be set and it can be higher than 1, then it should still be displayed correctly.

comment:6 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: closedreopened
Version: 4.0

You got me with that API.

Yes you are right - is select element for Dialogs allows size attribute then styles should be compatible with API

comment:7 Changed 6 years ago by Jakub Ś

Status: reopenedconfirmed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy