Opened 6 years ago

Closed 4 years ago

#11515 closed Bug (fixed)

Last item on bullet list ignored - Google chrome issue.

Reported by: sergio Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Blink Cc:

Description

I tested this error out on the demo page and it is happening there as well.

After entering a new list of items, separated by a line break, ex:

1<br /> 2<br /> 3

And then selecting the list and hitting the bullet list button, the last item is being ignored, resulting in:

<ul>

<li>1</li> <li>2</li>

</ul> 3

This happens only on Google chrome. If adding a line break on the last item this error does not occur. And also out of curiosity, this error also doesn't occur after viewing the "source" code and returning to add the bullet list. Also if using <p> as the line break there are no problems.

This isn't anything major but I think you would like to know that this is happening. It seems to be a simple compatibility issue regarding the text selection on chrome.

Please let me know how to proceed. Thank you for your time. Regards,

Sergio

Change History (5)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: bullet list removed
Status: newpending

I have tried default CKEditor Full package in Chrome 32 in Win7.

  1. I have entered
    1<br /> 2<br /> 3 
    
  2. Selected whole list with mouse/Ctrl+A/keyboard
  3. Pressed Bullet list button

Everything worked as expected.

Are you using one of predefined packages (full, standard, basic) or editor with some third-party plugins? Have you tried using editor without these plugins?

Have you tried checking this with custom browser plugins disabled?

comment:2 Changed 6 years ago by sergio

First of all thank you for the response.

I'm using a customized standard editor with no third party plugins.

As I said I am able to replicate the problem on your own Demo page. (http://ckeditor.com/demo)

The steps I took to replicating this on demo page:

  1. CTRL + A, to remove existing text in editor.
  2. I entered in: 1<br />2<br />3 (using SHIFT + ENTER for the linebreaks)
  3. Select bullet list, bottom to top, with mouse.
  4. Hit bullet list button.

Result: <ul>

<li> <h1>1</h1> </li> <li> <h1>2</h1> </li>

</ul>

<h1>3<br /> &nbsp;</h1>

I am using chrome 32 on Windows 7 as well.

comment:3 Changed 6 years ago by Jakub Ś

Keywords: Blink added
Status: pendingconfirmed
Version: 4.0

Thnk you for explanation - problem can be reproduced from CKEditor 4.0 full in Blink Browsers.

comment:4 in reply to:  3 Changed 6 years ago by sergio

Hi there.

I would like to know what the status is on this issue and if it's in the process of being fixed? Thanks.

Sergio

comment:5 Changed 4 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

No one is working on this issue however from what I can see it is no longer reproducible starting from CKEditor 4.5.0.

Please check latest version or CKEditor demo.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy