Opened 12 years ago

Closed 8 years ago

#1152 closed Bug (worksforme)

[IE] InsertHtml doesn't insert nodes at the cursor position when foucs is lost

Reported by: matan_a Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (FCKeditor) - Retired
Keywords: IE Cc:

Description

In IE6/7, when I use InsertHTML from outside the FCKEditor, meaning it is not in focus, it always inserts the nodes at the beginning of the page, not at the cursor position...

In FF it works fine.

Change History (4)

comment:1 Changed 12 years ago by christopher mahan

I'm experiencing the same problem on three different machines (2 Win XP, IE7, one Windows Vista IE7). Note these are actual machines, not VMs.

Works fine in Firefox on all three machines.

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

The fact is that IE doesn't preserve the selection in more than one window at the same time (in a frames tree). So, if you move the selection to another document (by clicking in a button that inserts the HTML, for example), the editor looses the selection.

For now, all I can tell is that it is a requirement to not make external documents to get the selection in such cases. Usually it is enough to set unselectable="on" on the target elements.

comment:3 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed IE added
Summary: InsertHTML and IE[IE] InsertHtml doesn't insert nodes at the cursor position when foucs is lost

comment:4 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy