Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#11611 closed Bug (fixed)

'change' is fired when pressing arrow keys in the editor

Reported by: Björn Weinbrenner Owned by: Marek Lewandowski
Priority: Normal Milestone: CKEditor 4.4.4
Component: Core : Undo & Redo Version: 4.2
Keywords: Firefox Cc:

Description

When I use the arrow keys to change the cursor position in the editor there is a 'change' event fired for every keypress although no changes are caused by the arrow keys.

I'd appreciate if arrow keys are detected and the 'change' event wouldn't be fired in this case. Or to replace keypress by another event (as reported earlier, see comment on http://dev.ckeditor.com/ticket/10926)

This only happens in Firefox (I use 27.0.1 on OSX at the moment). Chrome and Safari seem to be fine.

Change History (8)

comment:1 Changed 5 years ago by Jakub Ś

Keywords: Firefox added; change event firefox removed
Status: newconfirmed
Type: TaskBug
Version: 4.3.24.2

Problem can be reproduced from CKEditor 4.2 in Firefox only.

comment:2 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.2

Something is totally wrong now with the keypress listener and the change event fired on it. This ticket is strongly related to #11739. I'm adding both to 4.4.2.

comment:3 Changed 4 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: confirmedassigned

comment:4 Changed 4 years ago by Marek Lewandowski

FF does not only fire change event for arrows, but it also does it for:

  • f1-f12
  • insert / home / pgup / pgdn / end
  • esc / tab / pause (break)
  • even for media keys (such as play, next, volume up, mute)

For all the given keys Chrome does not fire keypress.

IE8, IE11 seems to behave same as Chrome, with the exception that it fires keypress for esc.

I'll start with #11739, maybe we can improve this thing by listeners reorganization.

comment:5 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.2CKEditor 4.4.3

As part of #11739 this ticket needs to be postponed too (http://dev.ckeditor.com/ticket/11739#comment:17).

comment:6 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.3CKEditor 4.4.4

The 4.4.3 milestone was shortened, so the remaining tickets must be postponed.

comment:7 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: assignedclosed

Mostly fixed in #11739. A follow-up ticket will be reported.

comment:8 Changed 4 years ago by Piotrek Koszuliński

Follow up: #12300.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy