Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#11644 closed Bug (fixed)

Number of rows must be a number greater than 0

Reported by: rajesh Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.5
Keywords: Cc: sudheer@…

Description

we are using Ckeditor version:'3.6.5' in our project.When we are trying to insert table through ckeditor than its throwing a validation as "Number of rows must be a number greater than 0".The above issue is occuring in all the browsers.

Attachments (1)

CKeditorIssue.docx (201.0 KB) - added by rajesh 5 years ago.
CkEditorIssue

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by rajesh

Attachment: CKeditorIssue.docx added

CkEditorIssue

comment:1 Changed 5 years ago by Jakub Ś

Status: newpending

I have tried this in default CKEditor 3.6.5, 3.6.6 and 4.x. None of editors with default settings had this problem. I wasn't able to get this on demo as well.

  1. Please upgrade your editor to at least CKEditor 3.6.6. I would however recommend upgrading to CKEditor 4.x.
  2. Please remove third-party plugins and core code changes if you have any.
  3. If none of above helps please provide more details that allow to reproduce this problem in CKEditor freshly downloaded from our page (without any core code changes or third-party plugins).

NOTE: Current Firefox is 27, please upgrade it as well.

comment:2 in reply to:  1 Changed 5 years ago by rajesh

Replying to j.swiderski:

Please verify with IE-10,IE-11 versions and Firefox -25.0.1 version.I have attached document of issue.Please go through document once.

comment:3 Changed 5 years ago by Jakub Ś

Please go through document once.

What do you think I did - just guessed? Your steps are basic steps to insert table and I have no problem with it.

Please check your problem in standalone fresh editor located outside of your application without any core code changes or third-pary plugins. Please check things I have written in my first comment.

comment:4 Changed 5 years ago by rajesh

Thanks for your suggestions.It was helpful in identifying and fixing the issue.The getValue()function is used in our application in one of js which is registered in the application page.The getValue()function also exists in Ckeditor.Both were conflicting and was causing the issue.Now we have fixed it.

comment:5 Changed 5 years ago by rajesh

Resolution: fixed
Status: pendingclosed

comment:6 Changed 2 years ago by Scott Alexander

I encountered this problem because we are using Zoho Google Adwords integration, which is supposed to be loaded on every page, and unfortunately also uses the getValue() function.

I would argue that it is a bug to have a function with a name as generic as "getValue()" in a 3rd party Javascript widget likely to be used with other 3rd party widgets; some care should be taken to avoid naming collisions.

For now I have to chose between the Zoho tracking or an alternative to CKEditor, at least on pages where I need the editor. Can you consider a name alteration or encapsulating the function inside a var?

comment:7 Changed 2 years ago by Jakub Ś

@sbalexander first of all I'm sorry for late reply.

Based on your findings, I have created a ticket #16722

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy