Opened 5 years ago

Closed 5 years ago

#11652 closed Bug (invalid)

Drag handle disappear on Chrome

Reported by: Roberto Owned by:
Priority: Normal Milestone:
Component: UI : Widgets Version:
Keywords: Cc:

Description

I'm using some widgets with Chrome on OSX 33.0.1750.146.

When I add a widget to the inline editor I cannot see the widget drag handle and the widget "yellow" marker.

Everything is ok with Safari and Firefox.

Attachments (4)

Schermata 2014-03-08 alle 17.12.26.png (408.0 KB) - added by Roberto 5 years ago.
Schermata 2014-03-08 alle 17.12.47.png (268.9 KB) - added by Roberto 5 years ago.
Schermata 2014-03-08 alle 18.48.31.png (192.0 KB) - added by Roberto 5 years ago.
build-config.js (2.0 KB) - added by Roberto 5 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Keywords: drag handle widget removed
Status: newpending
Version: 4.3.3

I've just checked image2 and placeholder widgets on inline editor on the same version of Chrome on OSX and everything works fine. Could you attach a sample on which this issue is reproducible?

Changed 5 years ago by Roberto

Changed 5 years ago by Roberto

comment:2 Changed 5 years ago by Roberto

I use your simple box widget (but with image2 is the same).

I load the widget in the inlineall sample file.

As you can see in Firefox I have handle and yellow borders, in chrome they disappear.

By the way if you want I can upload somewhere the whole directory also with my template.

Last edited 5 years ago by Roberto (previous) (diff)

Changed 5 years ago by Roberto

comment:3 Changed 5 years ago by Roberto

Added also Safari Screnshot. Now I will try on Windows.

comment:4 Changed 5 years ago by Roberto

The issue is caused by some extra plugins.

I downloaded the "full" package, added my widgets and everything is ok.

On my "custom" build created with your system she yellow outline and the drag handle are broken.

comment:5 Changed 5 years ago by Piotrek Koszuliński

I understand that the issue is caused by some 3rd party plugin. In this case this can be:

  • still a CKEditor's issue which should be fixed,
  • an issue provoked by 3rd party addon, which has to be fixed by the addon's author.

To verify that we need to know which plugin causes the issue. Could you check that?

comment:6 Changed 5 years ago by Roberto

Not easy for me, I'm a js beginner. I can upload a zip file with my coeditor downloaded package, or if you prefear I can upload the package online un a server.

comment:7 Changed 5 years ago by Piotrek Koszuliński

You should be able to find a build-config.js file in your CKEditor package. Please attach it here. It may help us.

Changed 5 years ago by Roberto

Attachment: build-config.js added

comment:8 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

I downloaded a CKEditor package using your build-config.js and everything works fine there on Chrome on OSX as well as on every other browser I checked.

Unfortunately, you have to debug this by yourself. Check if it's not a cache, inspect DOM and see if resize handler's CSS was loaded correctly and if it wasn't overwritten by your page's styles.

I'm closing the issue as invalid. But if you'll find any additional information that will change the situation, we'll reopen the ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy