Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11662 closed Bug (wontfix)

conflict with autogrow, divarea, magicline and sharedspace

Reported by: archetypemedia Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Setup

  • Setup config for an editor with magicline, autogrow, sharedspace and divarea.
  • Create an editor instance with a sharedspace toolbar elsewhere.

Bug

  • Any mouse movement over the editing area causes scrollbars to show up and disappear, almost like a flicker.
  • If you pause the mouse at the right moment, the scrollbars will stay, move again, and they disappear.
  • But the very first time the scrollbars show up (ie, first mouse move over editing area), the magicline red indicator shows up briefly behind the bottom scrollbars.

Notes:

  • The magicline indicator shows up and disappears so fast, I had to do a screen recording of it, and take a screenshot of the video. (attached)
  • Firefox: Flicker of scrollbars on/off starts right away.
  • Chrome: Flickering starts only after more content is added the affects vertical height of editor.
  • Some browsers the magicline indicator shows up in the bottom left corner, others bottom right.

This appears in both Windows and Linux Mint for Firefox and Chrome

  • Firefox version: 27.0.1
  • Chrome: 33.0.1750.149 (Linux Mint)
  • Chrome: 33.0.1750.146 (Windows 7)
  • IE 8/9: No issues. (everything works fine)

Attachments (1)

ckeditor_error.png (9.9 KB) - added by archetypemedia 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by archetypemedia

Attachment: ckeditor_error.png added

comment:1 Changed 5 years ago by Jakub Ś

Keywords: scrollbars autogrow magicline sharedspace divarea removed
Status: newpending
Version: 4.3.3

Could you provide sample HTML so that I could check it on same setup that is causing problems for you?

I have tried reproducing it on shared space sample but all worked as expected.

comment:2 Changed 5 years ago by archetypemedia

I figured out what is causing this:

There is 49px margin-top set for the HTML element on the page. When this is removed, this issue does not happen.

If this does not cause the problem for you, let me know, and I will provide full HTML sample of the error.

comment:3 Changed 5 years ago by archetypemedia

A quick follow up: I tried using padding-top, and it has the same effect. I also tried body vs html element, both have the same effect.

(fyi, the margin/padding-top on html/body element is based on the toolbar height)

comment:4 Changed 5 years ago by archetypemedia

One more follow up, this flicker/error only happens where there are certain number of lines of content, even number from around 8 and up. And after about 20 lines, it no longer happens.

comment:5 Changed 5 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: pendingclosed

Sorry for late answer. That's still not enough info for me, but I have a theory that your custom CSS styles are breaking magicline's styles, so it appears in a wrong place so scrollbar appears. This will explain why the scrollbar appears randomly and hides. You can disable your styles to confirm this. Perhaps you'll also be able to write them in a different way so they don't affect magicline.

I can't find a ticket right now, but this specific issue will be solved when magicline is rewritten with lineutils plugin, because then it will be moved out from the contents of the editor. However, page's styling may still affect it and this is general CSS'es problem and therefore it's a won't fix issue. Or rather "can't fix".

comment:6 Changed 5 years ago by Piotrek Koszuliński

PS. If you don't agree with my theory please attach a sample on which this issue will be reproducible. We can reopen it.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy