Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11710 closed Bug (invalid)

Directive extraPlugins - ignore spaces between multiple items

Reported by: Ivan Čentéš Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I can use the extraPlugins directive to include multiple plugins at once, by separating their names with a comma: "plugin1,plugin2,plugin3". But when I type a space after the commas (for better readability) CKEditor throws an error.

I think it should be able to split the values correctly, regardless the whitespace. So this should work: "plugin1, plugin2 , plugin3"

Change History (3)

comment:1 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

We have decided on certian format and then created code that works with that format. These are the rules and you should apply to them.

There is no issue here.

comment:2 Changed 5 years ago by Ivan Čentéš

Does CKEditor support plugin names with spaces in them? Because if not, then I don't understand why just throw this suggestion away. With nearly no additional work in the code you could make it easier to configure CKEditor.

But you are right, this is not a bug. Would it help, if I marked this as a feature request?

comment:3 Changed 5 years ago by Jakub Ś

In short we really, really see no reason to add extra code that improves only configuration readibility.

Again you could could try doing something like:

config.extraPlugins = ("plugin1, plugin2, pluugin3,  plugin4,  plugin5").replace(/ /g,"");
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy