Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#11715 closed Bug (fixed)

SCAYT enabled for ckeditor inline causes problems with widgets

Reported by: Sari Connard Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 4.3
Keywords: Cc:

Description

Steps to reproduce - I have provided a html file that demonstrates the bug.

This page shows four base ckeditor blocks:

  1. Ckeditor classic with scayt disabled on startup. This works when doubleclicking on the simplebox widget handle in upper left corner of widget.
  2. Ckeditor inline with scayt disabled on startup. This works when doubleclicking on the simplebox widget handle in upper left corner of widget.
  3. Ckeditor classic with scayt enabled on startup. This works when doubleclicking on the simplebox widget handle in upper left corner of widget.
  4. Ckeditor inline with scayt enabled on startup. This FAILS when doubleclicking on the simplebox widget handle in upper left corner of widget.

Browser and OS - Lenovo laptop, Ubuntu (v 12.04), Chrome(v 33.0.1750.152) and Firefox(v 28.0) Screenshot - see 2014-03-19_ckeditor_inline_widget_scayt_bug.png Sample data - see 2014-03-19_ckeditor_inline_widget_scayt_bug.html (this must be viewed in a webserver to get the scayt_autoStartup=true to work) Test case file - Using simplebox widget: https://github.com/ckeditor/ckeditor-docs-samples/commit/8793b94892aa7876156b01c32c59cdedc5b103b3 Build configuration -https://github.com/ckeditor/ckeditor-releases/commit/944d690c3d79c21efe3fce42b2ca231b08c4c909

Attachments (4)

2014-03-19_ckeditor_inline_widget_scayt_bug.html (6.4 KB) - added by Sari Connard 6 years ago.
Test case file using simplebox widget
2014-03-19_ckeditor_inline_widget_scayt_bug.png (79.1 KB) - added by Sari Connard 6 years ago.
screen shot
simplebox.rar (4.5 KB) - added by Artur Delura 6 years ago.
Reproduced bug with no jQuery
bug.html (6.3 KB) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by Sari Connard

Test case file using simplebox widget

Changed 6 years ago by Sari Connard

screen shot

comment:1 Changed 6 years ago by Wiktor Walc

Component: UI : WidgetsUI : Spell Checker
Keywords: scayt widgets inline removed

Changed 6 years ago by Artur Delura

Attachment: simplebox.rar added

Reproduced bug with no jQuery

comment:2 Changed 6 years ago by Artur Delura

This bug no longer occurs in prerelease version 4.4.0 (see attachment http://dev.ckeditor.com/attachment/ticket/11715/simplebox.rar)

comment:3 Changed 6 years ago by Jakub Ś

@a.delura are you completely sure of this?

I have used ckeditor-dev latest master, bug.html (you can put it in samples folder), your simplebox plugin version, plus latest WSC and SCAYT plugins (copy all three into plugins folder).

Once you open page and double-click on drag handler you won't get widget dialog. Have I missed something, made any mistake in checking or is the issue still reproducible?

Changed 6 years ago by Jakub Ś

Attachment: bug.html added

comment:4 Changed 6 years ago by Jakub Ś

@a.delura I'm confirming this ticket for now but please prove me wrong so that we can close it :)

comment:5 Changed 6 years ago by Jakub Ś

Status: newconfirmed
Version: 4.3.34.3

comment:6 Changed 5 years ago by Wiktor Walc

Resolution: fixed
Status: confirmedclosed

WFM in 4.4.7

Probably because of the reason mentioned in a comment by @a.delura:

This bug no longer occurs in prerelease version 4.4.0 (see attachment)

Last edited 5 years ago by Wiktor Walc (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy