Opened 6 years ago

Closed 6 years ago

#11748 closed Bug (invalid)

PhraseExpress gains wrong focus in CKEditor

Reported by: Manuel Gellfart Owned by:
Priority: Normal Milestone:
Component: Core : Focus Version: 4.0
Keywords: Cc: manuel.gellfart@…

Description

Hallo,

we are using PhraseExpress for quicker writing in our company. For our textfields we use the CKEditor. When using Phrases, which require inputs from an dialogue (which causes the browser to lose focus and fire the onblur event) the mouseposition while regaining focus is wrong and thus creates wrong inputs. This bug can be reproduced with your demo (http://ckeditor.com/demo#inline).

No image "screenbug.png" attached to Ticket #1

I already fixed the problem with a quick hack, which I put into a plugin. Because I'm also a developer ;)

If you want I could add my quickhack.

Best regards, Manuel Gellfart

Attachments (1)

screenbug.png (27.5 KB) - added by Manuel Gellfart 6 years ago.

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by Manuel Gellfart

Attachment: screenbug.png added

comment:1 Changed 6 years ago by Manuel Gellfart

Cc: manuel.gellfart@… added

comment:2 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

We haven't tried PhraseExpress but I don't think this is editor fault. If you open some new window and then want to insert some content at cursor position, you need to get and preserve selection (works best with editor.focus()) before opening such dialog. You can then style selected content (which works best) or insert HTML | Text. This is how custom plugins work.

I think this is implementation issue thus I'm closing this ticket as invalid. If you think otherwise please provide reduced HTML file showing this problem in code.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy